Project

General

Profile

action #86078

transactional-server test tests 'undefined state'

Added by dimstar over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2021-01-11
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_transactional_server@64bit fails in
boot_to_desktop

The snapshot to be tested in the linked test run was 20210108 - note though that the login greets the user with snapshot 20210107 ! So we obviously do not test what we meant to test.

I've tracked this down a bit - the parent task, create_hdd_transactional_server. correctly installs the disk image using 20210108, as we would expect. BUT, between installation and shutdown, there is a revert to 0107 happening!

In fact, this happens in the 'force_scheduled_tasks', which triggers all systems timers - in case of MicroOS that implies the transactional-update.timer, which in turn runs zypper dup.

At this time though, the repositories have NOT been switched to the snapshot to be tested, but still point to download.o.o (aka the last published snapshot) - we thus DOWNGRADE the system to a previous snapshot and then pass THIS on to the child test.

Solution is to put correct repos for the create hdd job:

  • zypper_clear_repos
  • zypper_ar
  • zypper_ref

Like we do here: https://openqa.opensuse.org/tests/1602616#

Test suite description

test transactional server.
Maintainer: Zaoliang Luo zluo@suse.com

Reproducible

Fails since (at least) Build 20210108

Expected result

Last good: 20210107 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov over 1 year ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)
  • Target version set to future

#2 Updated by riafarov over 1 year ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Target version changed from future to SLE 15 SP3

#3 Updated by oorlov over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to oorlov

#4 Updated by oorlov over 1 year ago

  • Status changed from In Progress to Feedback

#5 Updated by oorlov over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF