Project

General

Profile

action #81086

[SLE][Migration][SLE15SP3]test fails in bootloader_uefi

Added by coolgw 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-12-16
Due date:
% Done:

0%

Estimated time:
25.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-Migration-from-SLE15-SPx-x86_64-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi fails in
bootloader_uefi

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

Reproducible

Fails since (at least) Build 102.1

Expected result

Last good: 100.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw 12 months ago

/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5169063 --skip-download _GROUP=0 UEFI_PFLASH_CODE="/usr/share/qemu/ovmf-x86_64-code.bin" UEFI_PFLASH_VARS="/usr/share/qemu/ovmf-x86_64-vars.bin"
Created job #5177554: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5177554
barry:~/:[0]#

#2 Updated by okurz 12 months ago

coolgw wrote:

/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5169063 --skip-download _GROUP=0 UEFI_PFLASH_CODE="/usr/share/qemu/ovmf-x86_64-code.bin" UEFI_PFLASH_VARS="/usr/share/qemu/ovmf-x86_64-vars.bin"

Little hint. You can simplify this call to

openqa-clone-job --within-instance http://openqa.suse.de 5169063 _GROUP=0 UEFI_PFLASH_CODE="/usr/share/qemu/ovmf-x86_64-code.bin" UEFI_PFLASH_VARS="/usr/share/qemu/ovmf-x86_64-vars.bin"

so use openqa-clone-job from path and replace "--from + --host + --skip-download" with "--within-instance"

#3 Updated by coolgw 12 months ago

okurz wrote:

coolgw wrote:

/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 5169063 --skip-download _GROUP=0 UEFI_PFLASH_CODE="/usr/share/qemu/ovmf-x86_64-code.bin" UEFI_PFLASH_VARS="/usr/share/qemu/ovmf-x86_64-vars.bin"

Little hint. You can simplify this call to

openqa-clone-job --within-instance http://openqa.suse.de 5169063 _GROUP=0 UEFI_PFLASH_CODE="/usr/share/qemu/ovmf-x86_64-code.bin" UEFI_PFLASH_VARS="/usr/share/qemu/ovmf-x86_64-vars.bin"

so use openqa-clone-job from path and replace "--from + --host + --skip-download" with "--within-instance"

Thanks a lot :)

#4 Updated by coolgw 12 months ago

  • Status changed from New to In Progress

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199769: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199769
barry:~/:[0]#

#5 Updated by coolgw 12 months ago

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199769: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199769
barry:~/:[0]#

coolgw wrote:

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199769: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199769
barry:~/:[0]#

send_key f2 seems can not work, now we try to using esc.

#6 Updated by coolgw 12 months ago

coolgw wrote:

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199769: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199769
barry:~/:[0]#

coolgw wrote:

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199769: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199769
barry:~/:[0]#

send_key f2 seems can not work, now we try to using esc.

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199772: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199772

#7 Updated by coolgw 12 months ago

coolgw wrote:

coolgw wrote:

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199769: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199769
barry:~/:[0]#

coolgw wrote:

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199769: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199769
barry:~/:[0]#

send_key f2 seems can not work, now we try to using esc.

barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199772: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199772

Not related with esc or f2, the root cause is openqa send key too slow(x86 machine is fast), so we try to send reboot command.
barry:~/:[0]# /usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5169063
Created job #5199788: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5199788

#8 Updated by coolgw 12 months ago

rerun wiht BOOT_MENU=1
/usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5206612
Created job #5206618: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5206618

#11 Updated by coolgw 12 months ago

another fix for yast2_migration.pm
/usr/share/openqa/script/openqa-clone-custom-git-refspec https://github.com/coolgw/os-autoinst-distri-opensuse/tree/uefi http://openqa.suse.de/tests/5206612
Created job #5207362: sle-15-SP3-Migration-from-SLE15-SPx-x86_64-Build102.1-online_sles15sp2_pscc_basesys-srv-live-tsm_def_full_y_uefi@uefi -> http://openqa.suse.de/t5207362

#12 Updated by coolgw 11 months ago

  • Estimated time changed from 20.00 h to 25.00 h

#13 Updated by coolgw 11 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF