Project

General

Profile

action #80716

[qe-core][qem] Extend openssh testsuite with kex

Added by hurhaj 10 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

With bsc#1179242 there was a regression in openssh which broke one of the kex algorithms. Testing seems easy, can be done on localhost and does not look resource hungry. As such, we such add this (probably for all kex algorithms) to the test suite.

Reproducer from bug:ssh -o kexalgorithms=diffie-hellman-group-exchange-sha256 localhost

History

#1 Updated by tjyrinki_suse 8 months ago

  • Subject changed from [qem] Extend openssh testsuite with kex to [qe-core][qem] Extend openssh testsuite with kex
  • Status changed from New to Workable
  • Priority changed from Normal to Urgent
  • Start date deleted (2020-12-04)

Urgent priority because of stated regression.

#2 Updated by geor 8 months ago

  • Assignee set to geor

#3 Updated by geor 8 months ago

  • % Done changed from 0 to 80

I have proceeded to add tests for all available ciphers, key exchange algorithms, host key algorithms and mac algorithms. (PR)

#4 Updated by tjyrinki_suse 8 months ago

  • Status changed from Workable to In Progress

#5 Updated by geor 7 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

#6 Updated by geor 7 months ago

PR merged

Also available in: Atom PDF