Project

General

Profile

tickets #80566

Problem trying to setting up a nomail subscriptions on the mail lists.

Added by robin_listas over 1 year ago. Updated 25 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Mailing lists
Target version:
-
Start date:
2020-11-28
Due date:
% Done:

100%

Estimated time:

Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I am trying to configure three mail addresses on Postorious. I login using
my openSUSE ID, then I set up my ...@opensuse.org as the main address
(verified). Then I add two alternate addresses, one ...@telefonica.net and
another ...@gmx.es. All three verified.

I go to "Mailman Settings carlos", and there to "List based preferences".
I see for instance, that the list "factory.lists.opensuse" is listed
thrice (delivery disabled, enabled, enabled), but it does not say to what
address the status refers to. By elimination, I can guess that "disabled"
is the opensuse one, so I can guess that the first section that starts on
the first "factory.lists.opensuse" and ends just before the second
"factory.lists.opensuse" pertains to my opensuse address. But there is no
separation, no header.

Bug, setting?

Then, when changing my "delivery status" on the heroes list I got an
error and change did not take:

Invalid Parameter "delivery_status": Accepted Values are: enabled,
by_user, by_bounces, by_moderator, unknown.

I also changed preferred language for users-es.lists.opensuse.org and
users-es.lists.opensuse.org to Spanish and it did not take.


Cheers / Saludos,

Carlos E. R.
(from 15.1 x86_64 at Telcontar)

-----BEGIN PGP SIGNATURE-----

iHYEARECADYWIQQZEb51mJKK1KpcU/W1MxgcbY1H1QUCX8K26RgcY2FybG9zLmUu
ckBvcGVuc3VzZS5vcmcACgkQtTMYHG2NR9Uf0gCgjBQ6V6TJGejmGb3cdeYts/gj
fusAn113DBTgBFjSupvXJ4tjRIrPEcbu
=ZF0u
-----END PGP SIGNATURE-----


Admin mailing list -- admin@lists.opensuse.org
To unsubscribe, email admin-leave@lists.opensuse.org
List Netiquette: https://en.opensuse.org/openSUSE:Mailing_list_netiquette
List Archives: https://lists.opensuse.org/archives/list/admin@lists.opensuse.org

History

#1 Updated by hellcp over 1 year ago

This is quite obviously a bug, and I suspect postorius doesn't expect you to subscribe with more than one address to a mailing list. I would report that upstream to https://gitlab.com/mailman/postorius/-/issues, since mailman handles this just fine otherwise

#2 Updated by robin_listas over 1 year ago

Managed to fill issue at gitlab.

https://gitlab.com/mailman/postorius/-/issues/460

#3 Updated by robin_listas over 1 year ago

I got an answer fast:

Mark Sapiro @msapiro ยท 19 minutes ago Owner

The fact that the specific address isn't shown under list based preferences can be considered a bug, but I think it's more of an inconvenience.

In my case, I can tell because for the list to which I have 3 addresses subscribed, each has a different Delivery Mode.

The fact that attempting to change your delivery_status results in Invalid Parameter "delivery_status": is clearly a bug, but we need help from opensuse.org to determine the cause. I don't see this issue in my case with Postorius from the head of the GitLab branch. It may be an issue with an older version that's been fixed or something unique to opensuse.org. We would need to see the error information and traceback from Mailman's django log to say further.

The same applies to the preferred language issue. That too works for me.

#4 Updated by pjessen over 1 year ago

  • Category set to Mailing lists
  • Status changed from New to Feedback
  • Private changed from Yes to No

Okay, so we need you to reproduce the issue at a known time, then I can extract some logs etc. I'll try reproducing it as well, I'm sure I have three addresses too.

#5 Updated by pjessen over 1 year ago

Yes, I have three addresses with mailman. Under "Subscriptions" on https://lists.opensuse.org/manage/accounts/subscriptions/ I even see "per@computer.org" listed twice for test.lists, first as "regular" and "member", then as "none" and "nonmember". :-)

Under "List-based preferences", I see one entry for test.lists, with delivery status neither enabled nor disabled. 2nd entry is enabled. I can confirm that there is no address listed, which is not very helpful.

When I tried to change delivery status to disabled for factory.lists, I also got the message "Invalid Parameter "delivery_status": Accepted Values are: enabled, by_user, by_bounces, by_moderator, unknown. ", followed by "Your preferences have been updated. ".

#6 Updated by pjessen over 1 year ago

I am not sure which one "Mailman's django log" might be, but I'm guessing it might be "/var/log/mailman/uwsgi-error.log" - as far as I can tell from all the junk, there is nothing related to the issue here. If it is the right log, we have about 1.4Gb since December.

#7 Updated by pjessen over 1 year ago

aha, there is also "/var/lib/mailman_webui/logs/mailmansuite.log", that looks more promising.

#8 Updated by pjessen over 1 year ago

pjessen wrote:

aha, there is also "/var/lib/mailman_webui/logs/mailmansuite.log", that looks more promising.

Hmm, no. Nothing relevant since some time last night, which was only the usual "django.request Internal Server Error: /accounts..."

#9 Updated by robin_listas over 1 year ago

About testing the problem to produce a log, my second subscription to the heroes list has disappeared. If I look under the "subscription" tab, I'm reset to be subscribed only with my o.o alias (regular), and telefonica is (none). Somebody/something has disappeared my telefonica subscription. I'll have to resubscribe externally.

So I do the other test. I change

users-es.lists.opensuse.org to Spanish. I click save at 11:16 UTC
I get error message at 11:17
Invalid Parameter "delivery_status": Accepted Values are: enabled, by_user, by_bounces, by_moderator, unknown.

#10 Updated by hellcp over 1 year ago

  • Assignee set to hellcp

#11 Updated by pjessen 25 days ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

I believe we can consider this one as resolved. If not, please reopen.

Also available in: Atom PDF