Project

General

Profile

action #80184

[SLE][Migration][sle15sp3][Regression]test fails in reboot_gnome(IO::Socket::INET: connect: Connection timed out)

Added by coolgw over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-11-23
Due date:
% Done:

100%

Estimated time:
25.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-Regression-on-Migration-from-SLE12-SPx-s390x-offline_sles12sp4_ltss_pscc_sdk-asmm-contm-lgm-tcm-wsm_all_full@s390x-kvm-sle12 fails in
reboot_gnome

Test suite description

Reproducible

Fails since (at least) Build 33.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

called testapi::type_string
[2020-11-21T11:27:36.621 CET] [debug] <<< testapi::type_string(string="echo systemctl is-active sshd > \$pty\n", max_interval=250, wait_screen_changes=0, wait_still_screen=0, timeout=30, similarity_level=47)
[ 51.397969] named[1772]: listening on IPv6 interface eth0, fdac:3a0e:2478:1:b4ca:15e:7208:748f#53
[ 51.398743] named[1772]: listening on IPv6 interface eth0, fdac:3a0e:2478:1:5054:ff:fe9f:6bf6#53
systemctl is-active sshd
[2020-11-21T11:27:37.901 CET] [debug] tests/x11/reboot_gnome.pm:34 called opensusebasetest::wait_boot -> lib/opensusebasetest.pm:1080 called opensusebasetest::reconnect_s390 -> lib/opensusebasetest.pm:778 called utils::type_line_svirt -> lib/utils.pm:150 called testapi::wait_serial
[2020-11-21T11:27:37.901 CET] [debug] <<< testapi::wait_serial(record_output=undef, buffer_size=undef, timeout=90, regexp="active", no_regex=0, quiet=undef, expect_not_found=0)
active
susetest:~ #(B [2020-11-21T11:27:39.014 CET] [debug] >>> testapi::wait_serial: active: ok
[2020-11-21T11:27:39.015 CET] [debug] tests/x11/reboot_gnome.pm:34 called opensusebasetest::wait_boot -> lib/opensusebasetest.pm:1080 called opensusebasetest::reconnect_s390 -> lib/opensusebasetest.pm:786 called testapi::record_info
[2020-11-21T11:27:39.015 CET] [debug] <<< testapi::record_info(title="ssh port open", output="check for port 22 on 10.161.145.13 successful", result="ok")
[2020-11-21T11:27:39.129 CET] [debug] tests/x11/reboot_gnome.pm:34 called opensusebasetest::wait_boot -> lib/opensusebasetest.pm:1080 called opensusebasetest::reconnect_s390 -> lib/opensusebasetest.pm:802 called testapi::select_console
[2020-11-21T11:27:39.129 CET] [debug] <<< testapi::select_console(testapi_console="x11", await_console=0)
/usr/lib/os-autoinst/consoles/vnc_base.pm:62:{
"hostname" => "10.161.145.13",
"tty" => 2,
"port" => 5901,
"password" => "nots3cr3t"
}
[ 53.318052] sshd[2885]: error: kex_exchange_identification: Connection closed by remote host
2020-11-21T05:27:39.182054-05:00 susetest sshd[2885]: error: kex_exchange_identification: Connection closed by remote host
[ 72.682414] systemd[1]: systemd-localed.service: Succeeded.
[ 144.397976] dhcpd[2107]: DHCPREQUEST for 10.161.145.85 from 52:54:00:9d:f3:02 via eth0: unknown lease 10.161.145.85.
[ 145.398606] dhcpd[2107]: DHCPDISCOVER from 52:54:00:9d:f3:02 via eth0
[ 145.398996] dhcpd[2107]: DHCPREQUEST for 10.161.145.3 (10.161.159.12) from 52:54:00:9d:f3:02 via eth0: unknown lease 10.161.145.3.
[ 146.399701] dhcpd[2107]: DHCPOFFER on 10.161.145.253 to 52:54:00:9d:f3:02 (susetest) via eth0
[ 162.417774] systemd[1]: libvirtd.service: Succeeded.
[2020-11-21T11:29:48.534 CET] [info] ::: basetest::runtest: # Test died: Error connecting to VNC server 10.161.145.13:5901: IO::Socket::INET: connect: Connection timed out at /usr/lib/os-autoinst/testapi.pm line 1699.

History

#1 Updated by coolgw over 1 year ago

  • Priority changed from Normal to Low

#2 Updated by leli over 1 year ago

On build 92.1 reboot_gnome failed for "script timeout: rpm -q --queryformat '%{VERSION}' gnome-shell"
https://openqa.nue.suse.com/tests/5090013#
https://openqa.nue.suse.com/tests/5087021#step/reboot_gnome/13
https://openqa.nue.suse.com/tests/5087023#

#3 Updated by leli over 1 year ago

  • Assignee set to leli

#4 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp3_ltss_pscc_sdk-asmm-contm-lgm-tcm-wsm_all_full
https://openqa.suse.de/tests/5180356

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#5 Updated by coolgw over 1 year ago

  • Priority changed from Low to Normal

#6 Updated by coolgw over 1 year ago

  • Priority changed from Normal to Low

#7 Updated by coolgw over 1 year ago

  • Priority changed from Low to Normal

#8 Updated by leli over 1 year ago

From the log we can see two mac address and two ips for dhcp request, I suppose some regression test affect reboot_gnome. Try to only load reboot_gnome to check.

https://openqa.nue.suse.com/tests/5217928

#9 Updated by leli over 1 year ago

Need load desktop_runner to enter x11.

http://openqa.nue.suse.com/tests/5220315#live

#10 Updated by leli over 1 year ago

#11 Updated by leli over 1 year ago

https://openqa.nue.suse.com/tests/5225201#step/reboot_gnome/37
https://openqa.nue.suse.com/tests/5225204#step/reboot_gnome/37
We have workaround the conflict for pattern CFEngine in patch_sle, while the CFEngine is related with network for later system jobs. So I suppose the reboot issue may be caused by the workaround in patch_sle.

#12 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp5_pscc_sdk-asmm-contm-lgm-tcm-wsm_all_full
https://openqa.suse.de/tests/5248783

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#13 Updated by leli over 1 year ago

  • Status changed from New to Blocked

blocked by poo#87770

#14 Updated by leli over 1 year ago

Blocked by poo#56741

#15 Updated by leli about 1 year ago

  • Status changed from Blocked to In Progress
  • % Done changed from 0 to 20

To check the status of this ticket, just exclude the blocked check_service_status, wait http://openqa.nue.suse.com/tests/6010384

#16 Updated by leli about 1 year ago

Update the test results https://openqa.nue.suse.com/tests/6093177#step/reboot_gnome/37, seems the same issue.
Later I will try to add reset_consoles to workaround this.

#17 Updated by leli about 1 year ago

power_action('reboot', keepconsole => 1); -> power_action('reboot');

I think the keepconsole=1 may related with this issue.

Wait https://openqa.nue.suse.com/tests/6108154

#18 Updated by leli about 1 year ago

encounter the poo#56741, re-run https://openqa.nue.suse.com/tests/6109368#live

#19 Updated by leli about 1 year ago

Got a passed job. http://openqa.nue.suse.com/tests/6119303# Consider to file a PR for it.

#20 Updated by leli about 1 year ago

  • % Done changed from 20 to 50

#21 Updated by leli about 1 year ago

  • % Done changed from 50 to 60

PR merged, wait https://openqa.nue.suse.com/tests/6158370 to verify.

#22 Updated by leli about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

Also available in: Atom PDF