Project

General

Profile

action #77896

yast2_ftp test module assumes firewalld to use iptables

Added by dimstar almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-11-14
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_ncurses@64bit fails in
yast2_ftp

the test assumes iptables to be in use, even though firewalld is in progress of switching to nftables

We should use generic way commands to validate that port is open.
Also we need to check if test module is executed for older versions, like SLE 12, where we still have suse firewall.
If that's the case, we can check it using solution, like:

if ($self->firewall eq 'firewalld') {
...
}

Test suite description

Maintainer: qsf-y Test for yast2 UI, ncurses only. Running on created gnome images which provides both text console for ncurses UI tests as well as the gnome environment for the GUI tests.
riafarov set TIMEOUT_SCALE to improve stability of the test.

Reproducible

Fails since (at least) Build 20200801

Expected result

Last good: 20200731 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov almost 2 years ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)
  • Target version set to SLE 15 SP3

#2 Updated by riafarov almost 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#3 Updated by syrianidou_sofia almost 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to syrianidou_sofia

#5 Updated by syrianidou_sofia almost 2 years ago

  • Status changed from In Progress to Feedback

#6 Updated by syrianidou_sofia almost 2 years ago

  • Status changed from Feedback to Resolved

module passes in osd and o3

Also available in: Atom PDF