Project

General

Profile

action #76873

proxy.scc.suse.de for sle15sp3 is not set up correctly

Added by tonyyuan 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-11-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Repo: SUSE-PackageHub-15-SP3-Backports-Pool was incorrect.

This was found on Functional build 72.1.
I manually started the qcow2 image created by create_hd_gnome and login.
Ran below commands:

susetest:~ # cat /etc/SUSEConnect
---
insecure: false
url: http://all-72.1.proxy.scc.suse.de


susetest:~ # zypper ref
...
....................................................................................................[error]
Repository 'SUSE-PackageHub-15-SP3-Backports-Pool' is invalid.
[SUSE_Package_Hub_15_SP3_x86_64:SUSE-PackageHub-15-SP3-Backports-Pool|https://updates.suse.com/SUSE/Backports/SLE-15-SP3_x86_64/standard?0FI0VGOobSs2hc_LD_MvIzhAn3qvt91xKfaB9sj5Hnv_rmWn_I5ApwY9b_D7eLOW3elnhMnK5xgC2ZUQW1PsMo7cpRcADWSFAzEMY4XjjIc4_EdluQLEq5zTkylXKodI5kxUShnfrt8] Valid metadata not found at specified URL
History:
 - [SUSE_Package_Hub_15_SP3_x86_64:SUSE-PackageHub-15-SP3-Backports-Pool|https://updates.suse.com/SUSE/Backports/SLE-15-SP3_x86_64/standard?0FI0VGOobSs2hc_LD_MvIzhAn3qvt91xKfaB9sj5Hnv_rmWn_I5ApwY9b_D7eLOW3elnhMnK5xgC2ZUQW1PsMo7cpRcADWSFAzEMY4XjjIc4_EdluQLEq5zTkylXKodI5kxUShnfrt8] Repository type can't be determined.

Please check if the URIs defined for this repository are pointing to a valid repository.
Skipping repository 'SUSE-PackageHub-15-SP3-Backports-Pool' because of the above error.
Repository 'SUSE-PackageHub-15-SP3-Pool' is up to date.                                                                                                                         
Repository 'SLE-Module-Server-Applications15-SP3-Pool' is up to date.                                                                                                           
Repository 'SLE-Module-Server-Applications15-SP3-Updates' is up to date.                                                                                                        
Some of the repositories have not been refreshed because of an error.

History

#1 Updated by mkittler 9 months ago

  • Description updated (diff)

#2 Updated by riafarov 9 months ago

Problem is that PackageHub repos have different release cycle and was agreed not to be tested too.
So it's not an incorrect setup of the SCC proxy. Question which still remains why it's added, and in general it should also work, as url is the one our customers will get in their installations.

#3 Updated by okurz 9 months ago

  • Project changed from openQA Infrastructure to openQA Tests
  • Category set to Bugs in existing tests

definitely not something for "openQA infrastructure". If the backport repos are not setup yet for SLE15SP3 then please crosscheck the release manager's checklist if they sohuld have been ready at this point in the development of SLE15SP3. If they should be ready by now then please report a bug in bugzilla accordingly. If the answer is "no" then I can think of two possibilities: Ask RMs if the repo can be prepared earlier in product development cycles or exclude according tests and handle failures gracefully until the repo is ready

#4 Updated by maritawerner 9 months ago

The package hub repos will not be added before Beta1 and that can not change due to legal reasons. During the Alpha phase SLE related packages must not be published and have to stay SUSE internal. So please wait with all package hub related testcases till Beta1 is out. I am not sure when package hub will be enabled after Beta1 but then it is worth to file a bug.

#5 Updated by tonyyuan 9 months ago

Thanks for the information. Opened a bug. https://bugzilla.suse.com/show_bug.cgi?id=1178919

#6 Updated by tonyyuan 7 months ago

  • Status changed from New to Resolved

The package hub repo is already avaiable. close this ticket.

Also available in: Atom PDF