Project

General

Profile

action #73600

yast_virtualization: new detection of NM managed system

Added by dimstar almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-10-20
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-virtualization@64bit fails in
yast_virtualization

yast virtualization newly prompts the user about NM managed system, about bridge configuration not being auto-configured. This dialog is new, the test code unaware of it.

Preferable option would be to reonfigure the test suite to use image with wicked (created by create_hdd_gnome_wicked test suite).
Other option would be to assert that warning is shown and process it.

Test suite description

Maintainer: okurz. Test virtualization stack using libvirt and virt-manager.

Reproducible

Fails since (at least) Build 20200918

Expected result

Last good: 20200916 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov almost 2 years ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)
  • Target version set to SLE 15 SP3

#2 Updated by riafarov almost 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#3 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

#4 Updated by JERiveraMoya almost 2 years ago

  • Status changed from In Progress to Feedback

VR: https://openqa.opensuse.org/tests/1461315#step/yast_virtualization/14
Settings changed in OSD:

HDD_1=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-%DESKTOP%@%MACHINE%.qcow2 => HDD_1=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-gnome-wicked@%MACHINE%.qcow2
START_AFTER_TEST=create_hdd_gnome => START_AFTER_TEST=create_hdd_gnome_wicked
UEFI_PFLASH_VARS=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-%DESKTOP%@%MACHINE%-uefi-vars.qcow2 => UEFI_PFLASH_VARS=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-gnome-wicked@%MACHINE%-uefi-vars.qcow2

#5 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF