Project

General

Profile

action #70609

test fails in steamcmd

Added by dimstar over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-08-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_in_textmode@64bit fails in
steamcmd

/usr/lib/steamcmd/steamcmd.sh moved to /usr/libexec/steamcmd/steamcmd.sh (libexecdir change)
BUT: users are not supposed to worry for this at all: %{_libexecdir} is to be used internally by scripts.

The test is supposed to test what a user does: call 'steamcmd' (from /usr/bin)
Apparenlty, this was not done as the original script at the time had a bug :( so the bug was simply masked away and something tested which nobody does.

Test suite description

Maintainer: okurz@suse.de

Mainly console extratest.

Reproducible

Fails since (at least) Build 20200730

Expected result

Last good: 20200730 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dimstar over 2 years ago

  • Status changed from New to Resolved

Fixed in
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/10900

Let's start /usr/bin/steamcmd - as any user would

Also available in: Atom PDF