Project

General

Profile

action #68755

[functional][y] test fails in yast2_vnc ppc64le TW 2020707

Added by michel_mno 29 days ago. Updated 1 day ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - SLE 15 SP3
Start date:
2020-07-08
Due date:
2020-08-11
% Done:

0%

Estimated time:
5.00 h
Difficulty:
Duration: 25

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64le-yast2_ncurses@ppc64le fails in
yast2_vnc

two times same failure on TW 2020707
https://openqa.opensuse.org/tests/1326878#step/yast2_vnc/22
https://openqa.opensuse.org/tests/1326973#step/yast2_vnc/22

vnc service restart seems to fail.

Actual problem is soft-failure we have. So on the initial check port is still closed, so we try to start the service.
So I believe problem is that there is delay in the port openning, but service is running.
As test didn't fail in the last runs, we should at least remove soft-failure, and verify that service is running even when port is open.

It also would make sense to soften check, so we validate that port gets open in some time-frame (e.g. 30 seconds).

 sub check_service_listening {
     my $cmd_check_port = $is_older_product ? 'netstat' : 'ss -tln | grep -E LISTEN.*:5901';
     if (script_run($cmd_check_port)) {
         record_soft_failure 'boo#1088646 - service vncmanager is not started automatically';
         systemctl('status vncmanager', expect_false => 1);
         systemctl('restart vncmanager');
         systemctl('status vncmanager');
         assert_script_run $cmd_check_port;
     }
 }

Test suite description

Maintainer: qsf-y Test for yast2 UI, ncurses only. Running on created gnome images which provides both text console for ncurses UI tests as well as the gnome environment for the GUI tests.
riafarov set TIMEOUT_SCALE to improve stability of the test.

Reproducible

Fails since (at least) Build 20200707

Expected result

Last good: 20200706 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by michel_mno 29 days ago

as per reported logs, vnc-manager listen on port 5900, while test script grep for port 5901

=== extract autoinst-log
[2020-07-08T10:08:02.161 UTC] [debug] tests/console/yast2_vnc.pm:71 called yast2_vnc::check_service_listening -> tests/console/yast2_vnc.pm:49 called testapi::script_run
[2020-07-08T10:08:02.161 UTC] [debug] <<< testapi::script_run(cmd="ss -tln | grep -E LISTEN.*:5901", quiet=undef, output="", timeout=undef)
[2020-07-08T10:08:02.161 UTC] [debug] tests/console/yast2_vnc.pm:71 called yast2_vnc::check_service_listening -> tests/console/yast2_vnc.pm:49 called testapi::script_run
[2020-07-08T10:08:02.161 UTC] [debug] <<< testapi::type_string(string="ss -tln | grep -E LISTEN.*:5901", max_interval=250, wait_screen_changes=0, wait_still_screen=0, timeout=30, similarity_level=47)
===
$grep -i vnc yast2_vnc-connections.txt
tcp   LISTEN 0      32           0.0.0.0:5900       0.0.0.0:*    users:(("vncmanager",pid=11089,fd=5))
tcp   LISTEN 0      32              [::]:5900          [::]:*    users:(("vncmanager",pid=11089,fd=6))
===

#2 Updated by michel_mno 28 days ago

#3 Updated by riafarov 9 days ago

  • Subject changed from test fails in yast2_vnc ppc64le TW 2020707 to [functional][y] test fails in yast2_vnc ppc64le TW 2020707
  • Description updated (diff)
  • Due date set to 2020-08-11

#4 Updated by riafarov 8 days ago

  • Status changed from New to Workable
  • Target version set to SLE 15 SP3
  • Estimated time set to 5.00 h

#5 Updated by JRivrain 6 days ago

  • Status changed from Workable to In Progress
  • Assignee set to JRivrain

#6 Updated by JRivrain 3 days ago

  • Status changed from In Progress to Feedback

#7 Updated by JRivrain 1 day ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF