Project

General

Profile

action #67522

[SLE][Migration][SLE15SP2]test fails in grub_test - needle not match?

Added by coolgw over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-06-01
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP2-Migration-from-SLE15-SPX-to-SLE15-SP2-aarch64-offline_sles15sp1_media_basesys-srv-desk-dev_def_full@aarch64 fails in
grub_test

Test suite description

basesys+srv+desk+dev def p2/c/m p1/c/m

Reproducible

Fails since (at least) Build 203.1 (current job)

Expected result

Last good: 202.6 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by acarvajal over 2 years ago

Seems like the matching region in needle online_migration_setup-tianocore-select_opensuse_or_sles-20200527 is a little on the big side and works only when there is no text below <sles>.

Compare either https://openqa.suse.de/tests/4302975#step/boot_to_desktop/20 or https://openqa.suse.de/tests/4302975#step/patch_sle/106 vs https://openqa.suse.de/tests/4302975#step/grub_test/36. First two work, while in the third one, there's a match of only 90% and it fails. Only difference seems to be that there's a <BOOT> below <sles> in the later case.

I have reduced the matching region, and this has fixed the issue for HA migration tests.

#2 Updated by coolgw over 2 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF