Project

General

Profile

action #62366

[functional][u][svirt-xen-pv] test fails in shutdown - Misfunction of workaround to login in GDM with unselected user item

Added by SLindoMansilla 4 months ago. Updated 6 days ago.

Status:
Feedback
Priority:
High
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 30
Start date:
2020-01-20
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Reproducible

  • In scenario sle-15-SP2-Online-x86_64-create_hdd_gnome@svirt-xen-pv
  • Fails since Build 108.1
  • Current occurrence: build 126.1

Tasks

This ticket needs investigation. After the reason is known, try to fix it or re-refine the ticket again.

Expected result

Last good: 97.1

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #62249: [functional][y][aarch64] Wrong chain of workarounds, first_boot tries to log twice.Resolved2020-01-17

Blocked by openQA Tests - action #63769: [functional][y][JeOS] xen pv images boot with wrong screen resolution (WAS: virsh start failed at /usr/lib/os-autoinst/consoles/sshVirtsh.pm) Resolved2020-02-24

History

#1 Updated by SLindoMansilla 4 months ago

  • Related to action #62249: [functional][y][aarch64] Wrong chain of workarounds, first_boot tries to log twice. added

#2 Updated by SLindoMansilla 4 months ago

  • Subject changed from [functional][u] test fails in shutdown - Misfunction of workaround to login in GDM with unselected user item to [functional][u][svirt] test fails in shutdown - Misfunction of workaround to login in GDM with unselected user item

#3 Updated by SLindoMansilla 4 months ago

  • Subject changed from [functional][u][svirt] test fails in shutdown - Misfunction of workaround to login in GDM with unselected user item to [functional][u][svirt-xen-pv] test fails in shutdown - Misfunction of workaround to login in GDM with unselected user item

#4 Updated by maritawerner 4 months ago

  • Priority changed from Normal to High

This Testcase fails twice in osd. Could we get that fixed until beta2 in two weeks?

#5 Updated by SLindoMansilla 4 months ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Milestone 30

#6 Updated by zluo 4 months ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and checking...

#7 Updated by zluo 4 months ago

  • Status changed from In Progress to Blocked

https://bugzilla.suse.com/show_bug.cgi?id=1158218

So this looks atm a production to me. Set as blocked for now and check this later when the bug got fixed.

#8 Updated by SLindoMansilla 3 months ago

  • Status changed from Blocked to Workable

We think that the bgug mentioned is not related.
This needs more investigation.

Santi suggests to

  • remove the post_fail_hook in the shutdown module.
  • Statistical investigation
  • And check output with journalctl for "[FAILED] XEN xenstore"

#10 Updated by zluo 3 months ago

  • Status changed from Workable to In Progress

#11 Updated by zluo 3 months ago

  • Status changed from In Progress to Workable

according to info from szarate, prepare_system_shutdown from power_action_utils.pm makes trouble.

#12 Updated by zluo 3 months ago

https://openqa.suse.de/tests/3909661#step/shutdown/23 show that test got passed. I wanted to debug and paused on shutdown, and then let it continue...

#13 Updated by zluo 3 months ago

make sure that journald from previous module cleanup_before_shutdown
is active before starting shutdown, PR updated for try.

to check https://openqa.suse.de/tests/3909709

#14 Updated by zluo 3 months ago

it seems not working atm. trying: with extending timeout to $shutdown_timeout *= 5

to check https://openqa.suse.de/tests/3909740
https://openqa.suse.de/tests/3909750

#15 Updated by zluo 3 months ago

  • Status changed from Workable to In Progress

still not working atm.

to exclude cleanup_before_shutdown:

https://openqa.suse.de/tests/3913656

to extend timeout for SHUTDOWN_NEEDS_AUTH:

https://openqa.suse.de/tests/3913666

#16 Updated by zluo 3 months ago

https://openqa.suse.de/tests/3915371#step/bootloader_svirt/28

Now this is blocking my tests

https://openqa.suse.de/tests/3916862 (textmode, no gnome, just for checking)

#17 Updated by zluo 3 months ago

  • Status changed from In Progress to Blocked

https://progress.opensuse.org/issues/63769 filed and this blocks now.

#18 Updated by zluo 3 months ago

  • Blocked by action #63769: [functional][y][JeOS] xen pv images boot with wrong screen resolution (WAS: virsh start failed at /usr/lib/os-autoinst/consoles/sshVirtsh.pm) added

#19 Updated by mgriessmeier 3 months ago

that's blocked by the bug about first entry not selected, right? Can we close it?

#20 Updated by ybonatakis 3 months ago

This still happens apparently [0].

[0] https://openqa.suse.de/tests/3967557#

#21 Updated by zluo 2 months ago

bootloader_svirt works again, but user_setting is blocking now, let's wait for https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9780

#22 Updated by zluo 2 months ago

#23 Updated by zluo 2 months ago

  • Status changed from Blocked to In Progress

#24 Updated by zluo 2 months ago

File '/var/lib/openqa/cache/openqa.suse.de/tests/sle/lib/../schedule/yast/skip_registration/skip_registration@svirt-xen-pv.yaml' does not exist at /var/lib/openqa/cache/openqa.suse.de/tests/sle/lib/scheduler.pm line 109.
Compilation failed in require at /usr/bin/isotovideo line 289.

--

so this is another issue which blocks my checks.

But I think the initial has to do with boot/reboot.

#25 Updated by zluo 2 months ago

  • Status changed from In Progress to Rejected

reject it since this issue doesn't come up now

#26 Updated by SLindoMansilla 2 months ago

  • Status changed from Rejected to Workable

The issue that causes the failure is happening again
https://openqa.suse.de/tests/4010321#next_previous
:(

zluo, would you like me to take over?

#27 Updated by zluo 2 months ago

  • Assignee changed from zluo to SLindoMansilla

okay, please take over, thanks.

#28 Updated by SLindoMansilla 2 months ago

  • Status changed from Workable to In Progress

#30 Updated by SLindoMansilla 2 months ago

  • Status changed from In Progress to Feedback

#31 Updated by szarate about 2 months ago

As a first step, we could fix post fail hook so that it prints journal to screen, and save the screenshot, using type_string? or passing no_regex => 1 or expect_not_found => 1 so that it doesn't fail due to serial output not matching (like in this case), so that we actually know better, what happened in the SUT.

#32 Updated by okurz about 1 month ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: create_hdd_gnome@svirt-xen-pv
https://openqa.suse.de/tests/4135864

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#33 Updated by okurz 25 days ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: create_hdd_gnome@svirt-xen-pv
https://openqa.suse.de/tests/4186711

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#34 Updated by okurz 6 days ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: create_hdd_gnome@svirt-xen-pv
https://openqa.suse.de/tests/4261923

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

Also available in: Atom PDF