Project

General

Profile

action #61759

[qam] test fails in graphicsMagick

Added by msmeissn over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2020-01-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-Updates-x86_64-gnome@uefi fails in
graphicsMagick

Test suite description

Reproducible

Fails since (at least) Build 20191219-2

Expected result

Last good: 20191219-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by msmeissn over 1 year ago

This seems largely just a too long running script.

Priority Urgent as it currently blocks opoenSUSE Leap 15.1 maintenance.

#2 Updated by mgriessmeier over 1 year ago

  • Subject changed from test fails in graphicsMagick to [functional][u] test fails in graphicsMagick

#3 Updated by ilausuch over 1 year ago

  • Assignee set to ilausuch

#5 Updated by msmeissn over 1 year ago

  • Status changed from Resolved to New

The problem is still happening.

I think it takes longer ...

The call it does is:

gm convert -resize 10000x10000 degradation.png __1.png

which takes a lot of memory.

DOes the openqa VM job have enough memory?

#6 Updated by ilausuch over 1 year ago

I create a new PR relaxing the test to a comfortable 5000x1000 pixel side image. Hope
this size will be low enough

But the aim of this test was to ensure that big images were managed by graphicsmagick,
so, I am not sure we are testing that.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9295

msmeissn wrote:

The problem is still happening.

I think it takes longer ...

The call it does is:

gm convert -resize 10000x10000 degradation.png __1.png

which takes a lot of memory.

DOes the openqa VM job have enough memory?

#7 Updated by ilausuch over 1 year ago

  • Status changed from New to In Progress

#8 Updated by okurz over 1 year ago

PR merged.

#9 Updated by okurz over 1 year ago

  • Subject changed from [functional][u] test fails in graphicsMagick to [qam] test fails in graphicsMagick

worked on by QAM member for a QAM test.

ilausuch can you update the ticket status with a comment, e.g. is it actually finished? Then please set to "Resolved" with a link to a verification run on production showing that tests pass now.

Please see https://progress.opensuse.org/projects/openqatests/wiki#ticket-workflow for details about the ticket workflow.

#10 Updated by ilausuch over 1 year ago

  • Status changed from In Progress to Resolved

#11 Updated by ilausuch over 1 year ago

Done, Sorry to have it in in process when it was finished.

#12 Updated by okurz over 1 year ago

  • Status changed from Resolved to Feedback

I hope you don't mind. As a learning exercise I reopen the ticket and ask you to follow https://progress.opensuse.org/projects/openqatests/wiki#ticket-workflow , i.e. set to "Resolved" with a link to a verification run on production showing that tests pass now.

#13 Updated by ilausuch over 1 year ago

  • Status changed from Feedback to Resolved

#14 Updated by ilausuch over 1 year ago

  • Status changed from Resolved to Feedback

#15 Updated by ilausuch over 1 year ago

  • Status changed from Feedback to Resolved

I checked that in recent tests where this patch is applied graphicsmagick appears on green
https://openqa.opensuse.org/tests/1179258 (opensuse-15.1-DVD-Updates-x86_64)
I've updated the PR too https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9295

Thanks for your help

Also available in: Atom PDF