Project

General

Profile

action #61146

[migration] script_run call for `zypper dup -l` does not fail the tests in obvious way when there are conflicts (was: webui doesn't show red border when the test failed)

Added by mlin7442 over 2 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2019-12-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.2-NET-x86_64-zdup-Leap-15.0-kde@64bit_cirrus fails in
zdup

the error is happened at https://openqa.opensuse.org/tests/1116470#step/zdup/13 however webui doesn't show any red border in the any step of this test

Expected result

Red border should appeared.

History

#1 Updated by mkittler over 2 years ago

Note that the problem is most likely how the result has been recorded by os-autoinst and not within the web UI.

#2 Updated by tinita over 2 years ago

It looks like the zypper call is missing -n (or --non-interactive).
script_run("(zypper dup -l;echo ZYPPER-DONE) | tee /dev/$serialdev", 0);

#3 Updated by okurz over 2 years ago

  • Project changed from openQA Project to openQA Tests
  • Subject changed from webui doesn't show red border when the test failed to [migration] script_run call for `zypper dup -l` does not fail the tests in obvious way when there are conflicts (was: webui doesn't show red border when the test failed)
  • Category changed from Concrete Bugs to Enhancement to existing tests

I am not sure if adding -n is the intended way. About the original issue: the test API behaves as intended. script_run("(zypper dup -l;echo ZYPPER-DONE) | tee /dev/$serialdev", 0); is not evaluating return code of the script_run call and moreover with the parameter 0 the call does not wait for evaluation of the return code. This can be improved from test perspective but the underlying code behaves as designed.

#4 Updated by hjluo about 1 year ago

  • Assignee set to hjluo

#5 Updated by hjluo about 1 year ago

  • Status changed from New to Rejected

it passed in 695.1 https://openqa.opensuse.org/tests/1316859 as designed.
this issue here is that the zdup didn't get input at due time.
this test case didn't set WORKAROUND_DEPS=1 so it can input '1' and wait the timeout. which trigger to cleanup.

script_run("(zypper dup -l;echo ZYPPER-DONE) | tee /dev/$serialdev", 0);
if ($out =~ $zypper_dup_conflict) {
if (check_var("WORKAROUND_DEPS", '1')) {
record_info 'workaround dependencies';
send_key '1';
send_key 'ret';
}
else {
$self->result('fail');
save_screenshot;
return;
}

with the upper explanation, we'd reject it as not an issue.

Also available in: Atom PDF