Project

General

Profile

action #60317

[qe-core][qam] test fails in krb5: kinit failed "Credential cache directory ... does not exist" - re enable krb5

Added by michel_mno about 1 year ago. Updated 2 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-11-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

test fails in krb5:
"kinit: Credential cache directory /run/user/1002/krb5cc does not exist while getting default ccache"
as per https://openqa.opensuse.org/tests/1096277#step/krb5/54

most probably because of the hardcoded created dir (few lines before in krb5.pm) should be replaced by a dynamic one to match the id of tester user id.

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64le-extra_tests_in_textmode@ppc64le fails in
krb5

Test suite description

Maintainer: okurz@suse.de

Mainly console extratest.

Reproducible

Fails since (at least) Build 20180813

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by michel_mno about 1 year ago

This issue is reported on TW 20191125 ppc64le for krb5 test. But next snapshot 20191126 do not have anymore krb5 test because removed temporarily by commit https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/7e25b2ee0e0b779fcb8e6e7573c127736f6c5f0b

#2 Updated by szarate about 1 year ago

  • Subject changed from test fails in krb5: kinit failed "Credential cache directory ... does not exist" to [qam] test fails in krb5: kinit failed "Credential cache directory ... does not exist" - re enable krb5

#3 Updated by dzedro about 1 year ago

  • Assignee set to slemke

#4 Updated by tjyrinki_suse 2 months ago

  • Subject changed from [qam] test fails in krb5: kinit failed "Credential cache directory ... does not exist" - re enable krb5 to [qe-core][qam] test fails in krb5: kinit failed "Credential cache directory ... does not exist" - re enable krb5

Also available in: Atom PDF