action #59975

[functional][u] test fails in several modules (eog, gnome_music, wireshark, ImageMagick, ooffice, oomath, oocalc, evolution) - those modules were not scheduled before for allpatterns scenario

Added by SLindoMansilla 2 months ago. Updated about 1 month ago.

Status:ResolvedStart date:18/11/2019
Priority:UrgentDue date:
Assignee:jorauch% Done:

0%

Category:Bugs in existing testsEstimated time:42.00 hours
Target version:SUSE QA tests - Milestone 28
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-15-SP2-Online-x86_64-allpatterns@64bit fails in
eog

Tasks

  1. Find out why is those module scheduled for allpatterns scenario.
  2. Fix or remove those tests modules from allpatterns

Reproducible

Fails since (at least) Build 89.1

Expected result

Last good: sle-15-SP1-Installer-DVD-x86_64-Build228.2-we-module@64bit

Further details

Always latest result in this scenario: latest

History

#1 Updated by SLindoMansilla 2 months ago

  • Subject changed from [functional][u] test fails in eog - eog is not installed on SLE15-SP2 to [functional][u] test fails in several modules (eog, gnome_music, wireshark, ImageMagick, ooffice, oomath, oocalc, evolution) - those modules were not scheduled before for allpatterns scenario
  • Description updated (diff)

#2 Updated by SLindoMansilla about 1 month ago

  • Status changed from New to Workable
  • Priority changed from High to Urgent
  • Estimated time set to 42.00

We think this modules appear now because the new mediums make one of these functions to return true.

if (is_sle && (!is_server || we_is_applicable)) {
  loadtest "x11/eog";

It points to

sub is_server {
  return 1 if is_sles4sap();
  return 1 if is_sles4migration();
  return 1 if get_var('FLAVOR', '') =~ /^Server/;
  return 1 if get_var('PUBLIC_CLOUD');
  # If unified installer, we need to check SLE_PRODUCT
  return 0 if get_var('FLAVOR', '') !~ /^Installer-/;
  return check_var('SLE_PRODUCT', 'sles');
}

#3 Updated by SLindoMansilla about 1 month ago

  • Assignee set to jorauch

#4 Updated by SLindoMansilla about 1 month ago

  • Target version set to Milestone 28

#5 Updated by jorauch about 1 month ago

  • Status changed from Workable to Feedback

#6 Updated by jorauch about 1 month ago

Recheck with the next build after merge

#7 Updated by SLindoMansilla about 1 month ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF