Project

General

Profile

action #59864

[functional][y] autoyast_reinstall_gnome: fails in openSUSE_welcome

Added by dimstar about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2019-11-15
Due date:
2020-02-11
% Done:

0%

Estimated time:
5.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-autoyast_reinstall_gnome@64bit fails in
opensuse_welcome

Seems the 'installation' part is nowadays already closing openSUSE_welcome, incl disabling it on autostart, which leads to the module openSUSE_welcome actually no longer getting oS-welcome started at all. This seems to be a recent change - the last snapshot did not yet close/disable oS-welcome in 'installation' (QA step)

Suggested solution would be to remove processing of the welcome pop-up from the installation test module and reuse opensuse_welcome. This might affect autoyast installations on openSUSE.
Cheapest to deliver solution would be to just unschedule opensuse_welcome

Test suite description

Reproducible

Fails since (at least) Build 20191113

Expected result

Last good: 20191112 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov about 3 years ago

  • Due date set to 2019-12-31
  • Target version set to Milestone 30+

#2 Updated by okurz about 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: autoyast_reinstall_gnome
https://openqa.opensuse.org/tests/1100260

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#3 Updated by mgriessmeier about 3 years ago

  • Subject changed from autoyast_reinstall_gnome: fails in openSUSE_welcome to [functional][y] autoyast_reinstall_gnome: fails in openSUSE_welcome

#4 Updated by riafarov about 3 years ago

  • Due date changed from 2019-12-31 to 2020-01-28

#5 Updated by mgriessmeier about 3 years ago

  • Target version changed from Milestone 30+ to Milestone 30

bulk moved to M30 for revisiting

#6 Updated by riafarov about 3 years ago

We should not schedule opensuse_welcome after first_boot. We could have reused it though to handle this outside of installation test module.

#7 Updated by riafarov about 3 years ago

  • Description updated (diff)
  • Due date changed from 2020-01-28 to 2020-02-11
  • Status changed from New to Workable
  • Estimated time set to 5.00 h

#8 Updated by riafarov almost 3 years ago

  • Status changed from Workable to In Progress
  • Assignee set to riafarov

#10 Updated by riafarov almost 3 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF