action #58259

[qam] test fails in yast2_storage_ng, new behavior

Added by dzedro 4 months ago. Updated 4 months ago.

Status:ResolvedStart date:21/10/2019
Priority:NormalDue date:23/10/2019
Assignee:pstivanin% Done:

100%

Category:Bugs in existing testsEstimated time:1.00 hour
Target version:-
Difficulty:
Duration: 3

Description

Observation

openQA test in scenario sle-15-SP1-Server-DVD-Updates-x86_64-mau-extratests-yast2ui@64bit fails in
yast2_storage_ng

Test suite description

Run YaST2 GUI tests

Reproducible

Fails since (at least) Build 20191015-2

Expected result

Last good: 20191015-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pstivanin 4 months ago

  • Status changed from New to In Progress
  • Assignee set to pstivanin

#2 Updated by coolo 4 months ago

Shall we take this out for now or is there a fix on the horizon?

#3 Updated by pstivanin 4 months ago

  • Due date set to 25/10/2019
  • Start date changed from 16/10/2019 to 21/10/2019

I'll start working on it later today!

#4 Updated by pstivanin 4 months ago

  • Due date changed from 25/10/2019 to 23/10/2019
  • % Done changed from 0 to 100
  • Estimated time set to 1.00

That was actually not a new behavior but a sporadic bug. The key was sent before the window appeared, that's why it failed (busy worker? slow network?)
I couldn't reproduce it, but the fix I made should prevent that.

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8754/files

#5 Updated by pstivanin 4 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF