Project

General

Profile

action #57704

[qam] [yellow] random test fails in yast2_apparmor - timeout is hit

Added by slemke almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-10-04
Due date:
% Done:

100%

Estimated time:
1.00 h
Difficulty:
easy

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-Updates-x86_64-mau-extratests-yast2ui-textmode@64bit fails in
yast2_apparmor

Test suite description

Run console tests against aggregated test repo

Reproducible

Fails since (at least) Build 20190930-1

Expected result

Last good: 20190929-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolo almost 2 years ago

Any update here?

#2 Updated by slemke almost 2 years ago

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8685

I did some checks as this one fails are kind of random and usually occur more in the SLES12 code stream,
and indeed it takes some extra time in this ones, it seems to install the extra needed packages and after
that it does some internal processing(which give a fast popup) and then it finally opens the 'enable/disable' screen.
This PR gives it some extra seconds to do that.

#3 Updated by slemke almost 2 years ago

  • Status changed from New to In Progress
  • Difficulty set to easy

#4 Updated by coolo almost 2 years ago

Now it's a reproducible failure :)
https://openqa.suse.de/tests/3480877#step/yast2_apparmor/16 - I didn't want to blindly create a needle

#5 Updated by slemke almost 2 years ago

Seems the test will need another timeout improvement:

In line 109 it send and 'alt-end' combination to to jump to the last entry on the profiles list, right after that 'alt-end' it asserts the screen, it's possibly in heawy load scenarios this is taking the screenshot before the 'end of profiles' list is printed.
So I will add a 2 seconds 'col-down' in between.

thanks for keeping a eye on it!

#8 Updated by slemke almost 2 years ago

On it, seems to be 12.3 specific.

thanks!

#9 Updated by slemke almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Timeout issue is resolved.

Also available in: Atom PDF