Project

General

Profile

action #55916

[tools] test fails in patch_and_reboot - reboots system into installation

Added by msmeissn about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 27
Start date:
2019-08-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-Updates-x86_64-install_with_updates_kde@uefi-2G fails in
patch_and_reboot

Test suite description

Reproducible

Fails since (at least) Build 20190822-1

Expected result

Last good: 20190821-4 (or more recent)

Further details

Always latest result in this scenario: latest

Problem is that "reboot" now not just reboots, but seems to trigger the installation.


Related issues

Related to openQA Tests - action #56051: [opensuse] Test fails in bootloader_uefi - kde_live_upgrade_leap_15.0@aarch64 fails because it boots on HDD instead of ISOResolved2019-09-02

History

#1 Updated by msmeissn about 2 years ago

  • Subject changed from test fails in patch_and_reboot to test fails in patch_and_reboot - reboots system into installation

#2 Updated by msmeissn about 2 years ago

my suspicion its os-autoinst commit d0fd1301cb69119e315b741c94b8ec02a13221fd

#3 Updated by msmeissn about 2 years ago

  • Priority changed from Urgent to Immediate

please fix immediately. this breaks opensuse maintenance openqa.

#4 Updated by SLindoMansilla about 2 years ago

  • Subject changed from test fails in patch_and_reboot - reboots system into installation to [functional][y] test fails in patch_and_reboot - reboots system into installation

#5 Updated by mgriessmeier about 2 years ago

  • Subject changed from [functional][y] test fails in patch_and_reboot - reboots system into installation to [functional][u] test fails in patch_and_reboot - reboots system into installation
  • Status changed from New to In Progress
  • Assignee set to mgriessmeier
  • Target version set to Milestone 27

#6 Updated by mgriessmeier about 2 years ago

  • Subject changed from [functional][u] test fails in patch_and_reboot - reboots system into installation to [tools] test fails in patch_and_reboot - reboots system into installation
  • Assignee deleted (mgriessmeier)
  • so, there are no codechanges in the testcode
  • there is the mentioned git commit in os-autoinst, but the codepath is not executed in UEFI scenarios

so our main suspect is a change in the qemu behaviour (e.g. by update of the package on the worker)

we have checked openqaworker4 and the install date of the packages qemu and omvf were in july... so most likely also not the problem...

#7 Updated by mkittler about 2 years ago

Note that the os-autoinst version hasn't changed between the last good and the first failure of that kind.

#8 Updated by msmeissn about 2 years ago

  • Status changed from In Progress to New
  • Target version deleted (Milestone 27)

Hmm... It might be one of the updates... Not sure which one, perhaps qemu or shim.

#9 Updated by msmeissn about 2 years ago

  • Status changed from New to In Progress
  • Target version set to Milestone 27

#10 Updated by okurz about 2 years ago

  • Related to action #56051: [opensuse] Test fails in bootloader_uefi - kde_live_upgrade_leap_15.0@aarch64 fails because it boots on HDD instead of ISO added

#11 Updated by okurz about 2 years ago

  • Assignee set to okurz

let's see what I can do.

#12 Updated by okurz about 2 years ago

  • Status changed from In Progress to Feedback

tests look ok again since 2 days, e.g. https://openqa.opensuse.org/tests/1018361

  • Is there anything else left to do?
  • anyone knows if there was any explicit fix?

Btw, it's unfortunate that an "Immediate" ticket is not assigned for 5 days. A good fallback assignee group would be QAM for openSUSE openQA maintenance tests. I suggest to make them aware the next time. It seems no one from QAM is actively watching this progress project for triaging. This work is still mainly done by QSF-u – as a courtesy :)

#13 Updated by okurz about 2 years ago

  • Status changed from Feedback to Resolved

#14 Updated by msmeissn about 2 years ago

it is currently not there anymore as I checked.

I retracted test updates from the queue ...

Currently retracted is "shim".

It might fail secure boot and then go to install media I think.

Also available in: Atom PDF