action #55871

[qam] test fails in salt_master

Added by hurhaj 6 months ago. Updated 4 days ago.

Status:ResolvedStart date:23/08/2019
Priority:HighDue date:
Assignee:pdostal% Done:

40%

Category:Bugs in existing tests
Target version:-
Difficulty:
Duration:

Description

Observation

test produces unreliable results, probably needs some brooming

openQA test in scenario sle-15-Server-DVD-Updates-x86_64-qam-salt-master@64bit fails in
salt_master

Test suite description

Maintainer: pdostal@suse.cz, pcervinka@suse.cz

Reproducible

Fails since (at least) Build 20190822-2

Expected result

Last good: 20190822-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pdostal 6 months ago

  • Status changed from New to In Progress

#2 Updated by pdostal 6 months ago

  • % Done changed from 0 to 40

I already managed to fix some weak parts, get logs from both master and minions plus the event log from the master, the code is also more readable now.
I am considering to refactor also the salt.pm which is not multimachine but is in use on multiple locations and it will be also worth to extend the coverage.

#3 Updated by pdostal 6 months ago

  • Status changed from In Progress to Resolved

#4 Updated by okurz 5 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-salt-master
https://openqa.suse.de/tests/3412144

#5 Updated by osukup 5 months ago

  • Status changed from Resolved to Feedback
  • Priority changed from Normal to High

still randomly failing on SLE15SP1

#6 Updated by pdostal 4 days ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF