Project

General

Profile

action #54623

[sle][jeos][u] test fails in firstrun - booting timeout issue?

Added by zluo over 1 year ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 31
Start date:
2019-07-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

even 1000 seconds doesn't make this successful.

I tested this by increasing to 2000: http://f40.suse.de/tests/4420#step/firstrun/7
It works, but I am not sure that is really a timeout issue.

Observation

openQA test in scenario opensuse-Tumbleweed-JeOS-for-kvm-and-xen-x86_64-jeos-extra@64bit_virtio-2G fails in
firstrun

Test suite description

Same as jeos, plus some more tests.

Reproducible

Fails since (at least) Build 20190311

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by zluo over 1 year ago

  • Related to action #53663: [functional][u][jeos] test fails in znc, weechat and docker_image: sudo not installed added

#3 Updated by zluo over 1 year ago

https://openqa.opensuse.org/tests/989200/file/autoinst-log.txt

checked this and found post_fail_hook {assert_script_run('timedatectl'); }doesn't work in this situation if reboot is not successfully.

I try more test run before I can say that is more likely a product issue.

#4 Updated by zluo over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to zluo

#5 Updated by zluo over 1 year ago

  • Subject changed from [sle][jeos][u] test fails in firstrun - reboot doesn't work, timeout? to [sle][jeos][u] test fails in firstrun - VGA display issue?

compare http://f40.suse.de/tests/4431#step/firstrun/1
with http://f40.suse.de/tests/4443#step/firstrun/1

we can see that failed test run has problem with vga display.

#6 Updated by zluo over 1 year ago

  • Subject changed from [sle][jeos][u] test fails in firstrun - VGA display issue? to [sle][jeos][u] test fails in firstrun - booting timeout issue?

but this issue doesn't happened on OSD however.

#7 Updated by zluo over 1 year ago

"QEMUVGA" : "virtio" is used, just for record.

#8 Updated by zluo over 1 year ago

  • Related to deleted (action #53663: [functional][u][jeos] test fails in znc, weechat and docker_image: sudo not installed)

#10 Updated by zluo over 1 year ago

the results from tests runs shows too many failures.

#11 Updated by zluo over 1 year ago

https://openqa.opensuse.org/tests/991274#step/firstrun/3 shows ugly display issue.

and I found that most failure come from openqaworker1, openqaworker4.
other worker like imagetester:5 looks quite stabile.

#12 Updated by zluo over 1 year ago

http://f40.suse.de/tests/4618/file/autoinst-log.txt shows that it needs only about 20 seconds to get booting ready:

[2019-07-26T16:04:50.592 CEST] [debug] /var/lib/openqa/cache/f40.suse.de/tests/opensuse/tests/jeos/firstrun.pm:102 called utils::assert_screen_with_soft_timeout
[2019-07-26T16:04:50.592 CEST] [debug] <<< testapi::check_screen(mustmatch='linux-login', timeout=300)
[2019-07-26T16:04:50.616 CEST] [debug] no match: 299.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:04:51.605 CEST] [debug] no match: 298.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:04:52.595 CEST] [debug] no change: 297.9s
[2019-07-26T16:04:53.607 CEST] [debug] no match: 296.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:04:54.819 CEST] [debug] no match: 295.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:04:55.608 CEST] [debug] no match: 294.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:04:56.609 CEST] [debug] no match: 293.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:04:57.610 CEST] [debug] no match: 292.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:04:58.611 CEST] [debug] no match: 291.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:04:59.825 CEST] [debug] no match: 290.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:00.612 CEST] [debug] no match: 289.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:01.613 CEST] [debug] no match: 288.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:02.615 CEST] [debug] no match: 287.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:03.616 CEST] [debug] no match: 286.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:04.827 CEST] [debug] no match: 285.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:05.618 CEST] [debug] no match: 284.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:06.619 CEST] [debug] no match: 283.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:07.620 CEST] [debug] no match: 282.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:08.621 CEST] [debug] no match: 281.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:09.834 CEST] [debug] no match: 280.9s, best candidate: linux-login-20140916 (0.00)
[2019-07-26T16:05:10.679 CEST] [debug] >>> testapi::_handle_found_needle: found linux-login-autoyast-20160822, similarity 1.00 @ 78/751

So I think this is product issue which happens quite often obviously.

#14 Updated by zluo over 1 year ago

http://f40.suse.de/tests/4684#step/firstrun/1 shows another display issue, it looks like smaller windows here.

#15 Updated by zluo over 1 year ago

http://f40.suse.de/tests/4703#step/firstrun/10

a workaround is not possible because following tests rely on root_console which cannot be provided after this issue.

#16 Updated by zluo over 1 year ago

http://f40.suse.de/tests/4703#step/firstrun/10

a workaround is not possible because following tests rely on root_console which cannot be provided after this issue.

http://f40.suse.de/tests/4715#step/firstrun/9 show croak message, this is actually atm what I can do.

#17 Updated by zluo over 1 year ago

  • Target version set to Milestone 25

#18 Updated by zluo over 1 year ago

  • Status changed from In Progress to Feedback

#19 Updated by zluo over 1 year ago

pr got merged, needs to check on O3, however this is a sporadic issue.

#20 Updated by mgriessmeier over 1 year ago

  • Target version changed from Milestone 25 to Milestone 27

#21 Updated by mloviska about 1 year ago

Hi guys, I think you are dealing with following systemd issues on TW JeOS.
https://bugzilla.opensuse.org/show_bug.cgi?id=1145637

#22 Updated by mgriessmeier about 1 year ago

  • Status changed from Feedback to Blocked

#23 Updated by mgriessmeier about 1 year ago

  • Target version changed from Milestone 27 to Milestone 28

#24 Updated by mgriessmeier 11 months ago

  • Target version changed from Milestone 28 to Milestone 31

#25 Updated by mgriessmeier 9 months ago

  • Status changed from Blocked to Rejected

test wasn't executed in ages....

Also available in: Atom PDF