Project

General

Profile

action #53909

[qam] qam-test-xfstests_* fail in partition

Added by kgw_suse about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-07-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-Updates-x86_64-qam-xfstests_btrfs-generic+sle12@64bit fails in
partition

More equivalent fails:

sle-12-SP4-Server-DVD-Updates-x86_64-qam-xfstests_xfs-generic+sle12@64bit fails in
partition

openQA test in scenario sle-12-SP3-Server-DVD-Updates-x86_64-qam-xfstests_btrfs-generic+sle12@64bit fails in
partition

sle-12-SP3-Server-DVD-Updates-x86_64-qam-xfstests_xfs-generic+sle12@64bit fails in
partition

Upon invocation in test module partition script /usr/share/qa/qa_test_xfstests/partition.py
reports the error:

/usr/bin/env: 'python3': no such file or directory

A possible cause: QA RPM qa_test_xfstests does not feature a dependency on python3,
thus in case test module install of parent job create_hdd_xfstests installs
qa_test_xfs, this would not trigger the installation of the needed
python3-base package.

Reproducible

Fails since (at least) Build 20190704-2

Expected result

Last good: 20190704-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by yosun about 2 years ago

#2 Updated by vsvecova almost 2 years ago

  • Status changed from New to Resolved
  • Assignee set to yosun

This particular issue seems to be gone; the tests are still failing in 1_test_result but this is being handled within poo#51443.

Since there is a separate issue dealing with the other failure, I'm going to close this one as resolved.

Feel free to adjust status if you disagree.

Also available in: Atom PDF