Project

General

Profile

action #53009

[qam][blue] test fails in grub2_test - a different shortcut to be used on 12-SP1

Added by vsvecova about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-06-13
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

On SLE12-SP1, grub2_test gets stuck in the set password part of the test.

It appears that on SP1, a different keyboard shortcut is required to move to Bootloader Options (Alt+T as opposed to Alt+L on SP2, where the test is working fine)

openQA test in scenario sle-12-SP1-Server-DVD-Updates-x86_64-grub2_btrfs@uefi fails in
grub2_test

Test suite description

Reproducible

Fails since (at least) Build 20190612-1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dzedro about 3 years ago

  • Status changed from New to In Progress
  • Assignee set to dzedro

#2 Updated by dzedro about 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Fixed and added check for password protect, test could pass despite password was not set. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7683

#3 Updated by dzedro about 3 years ago

  • Subject changed from test fails in grub2_test - a different shortcut to be used on 12-SP1 to [qam][blue] test fails in grub2_test - a different shortcut to be used on 12-SP1

#4 Updated by dzedro about 3 years ago

I though I'm getting crazy, I was sure I have it correct but it still somehow didn't work, the thing is that on 12sp1 does the bootloader options tab kb shortcut alt-t, but when you press it the shortcut will change to alt-l & on 12sp1 non-UEFI is kb shortcut to activate password protect not alt-e but alt-a (alt-e is going back to first tab) ... https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7687

Also available in: Atom PDF