Project

General

Profile

action #51443

[qam][yellow] test fails in 1_ (xfstests_btrfs-generic-...)

Added by dzedro about 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-05-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Same test outputs before passed but now are failing despite positive result message 'Passed all 1 tests'.

generic-012

system-out:

FSTYP -- btrfs
PLATFORM -- Linux/x86_64 susetest 4.12.14-150.14-default
MKFS_OPTIONS -- /dev/vda5
MOUNT_OPTIONS -- /dev/vda5 /mnt/scratch

generic/012QA output created by 012
012 not run: xfs_io fcollapse failed (old kernel/wrong fs?)
[not run] xfs_io fcollapse failed (old kernel/wrong fs?)
Ran: generic/012
Not run: generic/012
Passed all 1 tests

Test suite description

xfstests btrfs category(btrfs/???) for btrfs filesystem. Parameters:

XFSTESTS: File system to be tested and xfstests category(e.g. btrfs-generic)
XFSTESTS_BLACKLIST: A coma seperated list of tests to be skipped(e.g. btrfs/001,btrfs/008)
set NO_KDUMP=1 to disable kdump

Reproducible

Fails since (at least) Build 20190512-1

Expected result

Last good: 20190511-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by yosun about 2 years ago

For description part in this ticket, the reason is that we consider skip test as a pass test. So it says pass all 1 test.

But the following link in that ticket "Reproducible" is a different case, and it's a very common fail in xfstests, the fail part it point out is https://openqa.suse.de/tests/2885523#step/1_/73
It means the test process is good, but it fails in the subtest generic/073. Need to debug with print out log and some extra logs inside following
https://openqa.suse.de/tests/2885523/file/log-generic.tar.xz
https://openqa.suse.de/tests/2885523/file/serial0.txt

This test totally follow upstream, so some times is test internal issue, some times is kernel issue, need to debug case by case.

#2 Updated by dzedro about 2 years ago

Thank you Sero. There are multiple failures,
xfstests_btrfs-generic-401-999 & xfstests_xfs-generic-401-999 tests is failing always since added on SLE15, 12SP4 and 12SP3.
On 12SP3 is failing xfstests_btrfs-generic-301-400. Somebody will look closer.

#4 Updated by jbaier_cz about 2 years ago

  • Assignee set to jbaier_cz

I am on it, some tests will be dropped, some reorganized.

#5 Updated by jbaier_cz about 2 years ago

  • Subject changed from [qam] test fails in 1_ (xfstests_btrfs-generic-...) to [qam][yellow] test fails in 1_ (xfstests_btrfs-generic-...)
  • Status changed from New to In Progress

#6 Updated by jbaier_cz about 2 years ago

  • Status changed from In Progress to Resolved

From this point, all xfstests for 12sp?/15 should be green.

#7 Updated by dzedro about 2 years ago

  • Status changed from Resolved to In Progress

xfstests are still failing, I guess due to split sometimes in test generate_report or in test 1_test_result

#8 Updated by okurz about 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-xfstests_btrfs-generic+sle12
https://openqa.suse.de/tests/3161569

#9 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-xfstests_btrfs-generic+sle12
https://openqa.suse.de/tests/3238541

#10 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-xfstests_btrfs-generic+sle12
https://openqa.suse.de/tests/3316257

#11 Updated by jbaier_cz 9 months ago

  • Status changed from In Progress to Closed
  • Assignee deleted (jbaier_cz)

Also available in: Atom PDF