Project

General

Profile

action #50729

[webui] Broken filtering with "Show only failures" in External results

Added by pvorel over 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Feature requests
Target version:
-
Start date:
2019-04-25
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

LTP test https://openqa.suse.de/tests/2823096#step/ADSP079/8 failed with

Test died: Timed out waiting for LTP test case which may still be running or the OS may have crashed! at /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/kernel/run_ltp.pm line 316.

But it's not shown in External results tab when filtering with "Show only failures.
Not sure if this is a problem of openQA search or test was not marked correctly by LTP module.

result_array.json.2823096 (84.9 KB) result_array.json.2823096 pvorel, 2019-04-25 07:57
serial0.txt.2823096 (146 KB) serial0.txt.2823096 pvorel, 2019-04-25 07:57
serial_terminal.txt.2823096 (119 KB) serial_terminal.txt.2823096 pvorel, 2019-04-25 07:57
vars.json.2823096 (7.43 KB) vars.json.2823096 pvorel, 2019-04-25 07:57
worker-log.txt.2823096 (138 KB) worker-log.txt.2823096 pvorel, 2019-04-25 07:57

History

#1 Updated by mkittler over 2 years ago

The filter is not broken here. The table for external results simply does not include that result because it is no external result. The result comes from os-autoinst/tests-distri itself.

Would it always makes sense to add text results to the "External results" table (if one is present)? Then I could implement it as simple as doing that. The "External results" table would then possibly show output from the external tool mixed with output from regular test API functions. That doesn't sound nice to me.

Otherwise you could replace the die in run_ltp.pm with code which would add an external test result similar to write_extra_test_result. That would likely be the right thing to do. If it is inconvenient there could be a helper for this.

#2 Updated by okurz over 2 years ago

  • Subject changed from [tools][functional] Broken filtering with "Show only failures" in External results to [webui] Broken filtering with "Show only failures" in External results
  • Category changed from 124 to Feature requests

#3 Updated by coolo about 2 years ago

  • Status changed from New to Rejected

To me it looks like the reporter accepted it's not a bug

Also available in: Atom PDF