action #49640

[aarch64][jeos][y] test fails in yast2_i

Added by ggardet_arm 2 months ago. Updated about 1 month ago.

Status:ResolvedStart date:25/03/2019
Priority:NormalDue date:23/04/2019
Assignee:mloviska% Done:

0%

Category:Bugs in existing testsEstimated time:3.00 hours
Target version:SUSE QA tests - Milestone 24
Difficulty:
Duration: 22

Description

Observation

There is same issue on jeos leap 15
openQA test in scenario opensuse-15.1-JeOS-for-AArch64-aarch64-jeos@aarch64-HD24G fails in
yast2_i

Test suite description

Maintainer: fvogt, mnowak

Start JeOS from the HDD image, configure it using the firstboot wizard and then run basic tests. console=tty0 added as needed for aarch64.

Let's consider to try predict if there are any packages to be suggested (might be that zypper -inr lists those), if nothing is easy to do, simply create needle.

Reproducible

Fails since (at least) Build 5.14

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

'Filter' is not set on 'Search' but on 'Installation Summary' before searching for NFS package name. So, type_string("$pkgname\n"); fails as it is not in the search box.
This is probably because on first screen, yast2-preselected-driver matched instead of empty-yast2-sw_single. So, this case must be handled to set Filter to Search before trying to type anything.


Related issues

Related to openQA Tests - action #49688: [functional][y] Review the yast2_i module Resolved 26/03/2019 23/04/2019

History

#1 Updated by riafarov about 1 month ago

  • Due date set to 23/04/2019

It's not clear if test misbehaves, or package is not available on jeos.

#2 Updated by riafarov about 1 month ago

  • Target version set to Milestone 24

#3 Updated by mloviska about 1 month ago

  • Assignee set to mloviska

there is also another issue related to empty-yast2-sw_single

#4 Updated by riafarov about 1 month ago

mloviska wrote:

there is also another issue related to empty-yast2-sw_single

Second one looks like missing needle for yast2-preselected-driver

#5 Updated by mloviska about 1 month ago

riafarov wrote:

mloviska wrote:

there is also another issue related to empty-yast2-sw_single

Second one looks like missing needle for yast2-preselected-driver

There is a different value in the filter field. We are expecting Search instead of Installation summary.
As long as the packages are the same yast2-packager-4.1.36-1.4 I suspect that we can set the default filter value somehow.

#6 Updated by riafarov about 1 month ago

  • Description updated (diff)
  • Estimated time set to 3.00

#7 Updated by riafarov about 1 month ago

  • Status changed from New to Workable

#8 Updated by mloviska about 1 month ago

  • Status changed from Workable to In Progress

zypper -n inr -D shows:

Refreshing service 'Basesystem_Module_15_SP1_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Server_15_SP1_x86_64'.
Refreshing service 'Server_Applications_Module_15_SP1_x86_64'.
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following 2 NEW packages are going to be installed:
  qemu-guest-agent ucode-intel

2 new packages to install.
Overall download size: 2.1 MiB. Already cached: 0 B. After the operation, additional 2.6 MiB will be used.
Continue? [y/n/v/...? shows all options] (y): y

Which is the same as https://openqa.suse.de/tests/2778262#step/yast2_i/8

#9 Updated by mloviska about 1 month ago

zypper inr recommends to install 2 nfs packages, but yast2 sw_single does not detect any automatic update, therefore filter is set to search.

#10 Updated by mloviska about 1 month ago

  • Status changed from In Progress to Feedback

#11 Updated by mloviska about 1 month ago

  • Related to action #49688: [functional][y] Review the yast2_i module added

#12 Updated by mloviska about 1 month ago

reported issue with yast2_i after PR merge. Filter button is not pressed on TW aarch64. See comments on the PR. As of now sle seems to be fine

#13 Updated by ggardet_arm about 1 month ago

mloviska wrote:

reported issue with yast2_i after PR merge. Filter button is not pressed on TW aarch64. See comments on the PR. As of now sle seems to be fine

Related poo ticket is here: https://progress.opensuse.org/issues/50495

#14 Updated by riafarov about 1 month ago

  • Status changed from Feedback to Resolved

Mentioned part is fixed, other failures will be fixed in #50495

Also available in: Atom PDF