Project

General

Profile

action #48704

[sle][functional][u] test fails in kdump_and_crash - apply a workaround for x86_64 (as well)

Added by okurz over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 25
Start date:
2019-03-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

recreated after accidential deletion by another user:

kdump_utils

sub activate_kdump

do {
        assert_screen \@tags, 300;
        # for ppc64le and aarch64 we need increase kdump memory, see bsc#957053 and bsc#1120566
        if (check_var('ARCH', 'ppc64le') || check_var('ARCH', 'aarch64')) {
            wait_screen_change { send_key 'alt-y' };
            type_string '640';
            send_key 'ret';
            record_soft_failure 'increase kdump memory size or kdumptool gets killed by OOM, bsc#1120566';
        }

Since this is happening on x86_64 as well, we should apply the workaround for openSUSE as well.

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_in_textmode@64bit fails in
kdump_and_crash

Reproducible

Fails since (at least) Build 20180714

Expected result

Last good: 20180714 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz over 2 years ago

Comment from yosun:
A yast problem block activate_kdump, yast2 kdump no longer exist. I'm writing a new function "activate_kdump_without_yast" in ./lib/kdump_utils.pm, could try to replace activate_kdump to activate_kdump_without_yast, after I finish my PR.

#2 Updated by okurz over 2 years ago

  • Description updated (diff)

yosun I do not know how you came to the conclusion that yast2-kdump would not exist anymore because it is still there. I do not recommend to replace the existing functionality using the yast dialogs.

#3 Updated by yosun over 2 years ago

okurz wrote:

yosun I do not know how you came to the conclusion that yast2-kdump would not exist anymore because it is still there. I do not recommend to replace the existing functionality using the yast dialogs.

Yeah, I found I was wrong, and I was willing to remove it to not confuse others, then I suddenly found the "remove" button :D

But FYI, I got a PR to enable kdump without yast. https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6959

#4 Updated by okurz over 2 years ago

  • Subject changed from [sle][functional][u] test fails in kdump_and_crash - apply workaround for x86_64 as well to [sle][functional][u] test fails in kdump_and_crash - apply a workaround for x86_64 (as well)
  • Status changed from Workable to Blocked
  • Assignee changed from zluo to okurz
  • Target version changed from Milestone 24 to Milestone 25

zluo sorry because the original ticket was originally deleted I do not know anymore why you are assigned. Unassigning. I set the "Blocker" flag on the bug https://bugzilla.opensuse.org/show_bug.cgi?id=1115946 which is the one to use for x86_64, not the one mentioned in the description pointing to what looks like an aarch64 specific problem. In general I think a workaround would be a good idea though but not loosing the coverage of yast2 kdump.

For now blocked by the bug https://bugzilla.opensuse.org/show_bug.cgi?id=1115946

#5 Updated by okurz over 2 years ago

  • Assignee changed from okurz to mgriessmeier

Move to new QSF-u PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-u. Feel free to discuss with me or reassign to me or someone else in this case. Thanks.

#6 Updated by mgriessmeier over 2 years ago

  • Status changed from Blocked to Resolved

didn't happen for two month - I consider this fixed

Also available in: Atom PDF