tickets #48350

Access to a connect platform to test delete spam

Added by robin_listas about 1 year ago. Updated 2 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:servers hosted in NBG
Target version:-
Duration:

Description

Hello, Heroes team

You may know (or not), that opensuse-project mailing list is heavily
discussing the shutdown of connect and the replacement by something else.

As temporary measure, some of us want to try remove the spam on the
https://connect.opensuse.org/, while others discuss and try a
replacement. We would need some kind of access to the platform.

any hint appreciated

Cheers / Saludos,

    Carlos E. R.
    (from 15.0 x86_64 at Telcontar)

signature.asc (195 Bytes) robin_listas, 23/02/2019 07:26 pm

History

#1 Updated by cboltz 12 months ago

  • Category set to servers hosted in NBG
  • Status changed from New to Closed

Thanks for volunteering to clean up all the messWspam!

I just made you admin on connect.opensuse.org. The admin role is "all or nothing", so please be a bit careful where you click ;-)

Quick manual how to delete spammers:
- go to the spammer's page, for example https://connect.opensuse.org/pg/profile/swipenclean
- click the "Delete" link in the left column

There's also a "Ban" link, but all it does is adding a header saying "this user has been banned", so it isn't too useful IMHO.

If you have questions, feel free to ask ;-)

#2 Updated by cboltz 12 months ago

Additional info: To delete a group, you first have to click "Edit group". Then scroll down and click the "Delete group" at the bottom of the page.

#3 Updated by robin_listas 12 months ago

  • Status changed from Closed to New

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Monday, 2019-02-25 at 20:39 -0000, admin@opensuse.org wrote:

[openSUSE Tracker]

Issue #48350 has been updated by cboltz.


Category set to servers hosted in NBG

Status changed from New to Closed


Thanks for volunteering to clean up all the messWspam!


I just made you admin on connect.opensuse.org. The admin role is "all or nothing", so please be a bit careful where you click ;-)

Thanks!

I'll be careful, but I also hope there are backups in case of emergency :-)

Quick manual how to delete spammers:

- go to the spammer's page, for example https://connect.opensuse.org/pg/profile/swipenclean

- click the "Delete" link in the left column


There's also a "Ban" link, but all it does is adding a header saying "this user has been banned", so it isn't too useful IMHO.


If you have questions, feel free to ask ;-)

One doubt.

I hope delete a user acts only on the connect platform, not on all of
them? Because it was mentioned that some users could also be SUSE / Novell
/ Microfocus customers.


Cheers,
Carlos E. R.
(from openSUSE 15.0 x86_64 at Telcontar)

-----BEGIN PGP SIGNATURE-----

iHYEARECADYWIQQZEb51mJKK1KpcU/W1MxgcbY1H1QUCXHUTwRgcY2FybG9zLmUu
ckBvcGVuc3VzZS5vcmcACgkQtTMYHG2NR9VGlgCffE0ntS2urS/P9tKa4TtGpqDO
kxwAnivIoPfS/fsDyuzfDgIaXNyhVAkn
=jqND
-----END PGP SIGNATURE-----

#4 Updated by cboltz 12 months ago

  • Private changed from Yes to No

I'll be careful, but I also hope there are backups in case of emergency :-)

Yes, now we have one ;-)

I hope delete a user acts only on the connect platform, not on all of them?

Because it was mentioned that some users could also be SUSE / Novell / Microfocus customers.

If a paying customer is spamming us, I would call breaking his account a feature, not a bug ;-) (and happily have a discussion with SUSE/Novell/MF) - but sadly the deletion only affects connect.opensuse.org.

BTW: Seife told me two useful things:
- I was wrong when I said that "Ban" is useless. There seem to be some spammers that come back, and banning them (and making all fields empty and/or private) prevents that. https://connect.opensuse.org/pg/profile/breslauerwarren is such an example.
- groups get auto-deleted when you delete the group creator

#5 Updated by lrupp 2 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF