Project

General

Profile

action #48287

[sle][migration][SLE15SP1]test fails in welcome - seems alt-a not send in code

Added by coolgw over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-02-22
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-s390x-offline_sles12sp3_pscc_all_full_zVM_preparation@s390x-zVM-Upgrade-sp2 fails in
welcome

Test suite description

Reproducible

Fails since (at least) Build 174.1

Expected result

Last good: 173.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by leli over 3 years ago

  • Assignee set to leli

Check the code change history to see if the code update caused regression issue.

#2 Updated by leli over 3 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

It failed for entering 'select the product' for SLE15SP1, while this case is for preparation installation of sle12sp3 for migration. Add the setting Version=12-SP3/12-SP4/15, then the issue fixed.

#3 Updated by leli over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#5 Updated by leli over 3 years ago

  • Status changed from Resolved to In Progress
  • % Done changed from 100 to 50

We need to distinguish the preparation test cases from other migration test cases. Now the case failed for the function has_product_selection return true.
sub has_product_selection {
if (is_sle('15+') && !get_var('UPGRADE')) {
return is_sle('>=15-SP1') || !is_s390x();
}
}

The function can be updated to below line since such preparation test should has the variable 'BASE_VERSION' and won't have 'UPGRADE'.
if (is_sle('15+') && !get_var('UPGRADE') && !get_var('BASE_VERSION') {

#6 Updated by leli over 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

Also available in: Atom PDF