action #47906

[sle][qam][yellow] test fails in docker_image - never worked before

Added by zluo about 1 year ago. Updated 4 days ago.

Status:ResolvedStart date:14/02/2019
Priority:HighDue date:
Assignee:pdostal% Done:

100%

Category:Bugs in existing tests
Target version:SUSE QA tests - Milestone 30
Difficulty:
Duration:

Description

I see that this is a new test module added on osd recently but it has never worked before:

Test died: command 'docker container run --entrypoint '/bin/bash' --rm registry.suse.de/suse/sle-15-sp1/update/cr/images/suse/sle15:15.1 -c 'zypper lr -s'' failed at /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/console/docker_image.pm line 68

Before this I see problem with retrieving repo index file for service 'container-suseconnect-zypp'

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-extra_tests_in_textmode@64bit fails in
docker_image

Test suite description

Maintainer: asmorodskyi,okurz
Mainly console extratest

Reproducible

Fails since (at least) Build 159.1

Expected result

Last good: no

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz about 1 year ago

  • Subject changed from [sle][functional][u] test fails in docker_image - never worked before to [sle][qam] test fails in docker_image - never worked before
  • Assignee set to pdostal
  • Priority changed from Normal to High
  • Target version set to Milestone 23

assigning to test module maintainer, pdostal, can you take a look, please?

#2 Updated by pdostal 12 months ago

Hello, I consulted this with @fvogt and perhaps this is a product bug the bsc#1127030 was opened.

#3 Updated by szarate 12 months ago

  • Status changed from New to Workable

I wonder if pdostal or somebody else could give it a look to check if it works on SLE15 SP1

#5 Updated by okurz 12 months ago

@pdostal do you want to work on this in the tests or set the ticket to "Blocked" by the bug?

#6 Updated by pdostal 11 months ago

  • Status changed from Workable to Blocked

We can just exclude 15.1 as a temporary solution but I would rather keep it visible until the bsc#1127030 is resolved.

#7 Updated by pdostal 11 months ago

  • Subject changed from [sle][qam] test fails in docker_image - never worked before to [sle][qam][yellow] test fails in docker_image - never worked before

#8 Updated by mgriessmeier 11 months ago

  • Target version changed from Milestone 23 to Milestone 24

moving to M24

#9 Updated by mgriessmeier 9 months ago

  • Target version changed from Milestone 24 to Milestone 25

#10 Updated by mgriessmeier 8 months ago

  • Target version changed from Milestone 25 to Milestone 26

#11 Updated by mgriessmeier 6 months ago

  • Target version changed from Milestone 26 to Milestone 28

any update?

#12 Updated by pdostal 6 months ago

  • Status changed from Blocked to In Progress
  • % Done changed from 0 to 30

This still contains at least timing issues. I am currently working on it.

#13 Updated by pdostal 5 months ago

  • % Done changed from 30 to 60

My pull request is waiting for some reviews.
However those issues seems to be very random.

I hope I made it more stable, this probably needs a closer look.

#14 Updated by pdostal 5 months ago

  • % Done changed from 60 to 80

The last pull request helped, but next one is needed.

#15 Updated by mgriessmeier about 1 month ago

  • Target version changed from Milestone 28 to Milestone 30

pdostal wrote:

The last pull request helped, but [next one] is needed.


[next one]: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8562

can we close this then?

#16 Updated by pdostal 4 days ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

This one definitely can be closed. See current mau-extratests-docker@64bit results for 12.4 12.5 15 15.1

Also available in: Atom PDF