Project

General

Profile

action #45119

[sle][migration][SLE15SP1]test fails in upgrade_snapshots - snapper list need more time to finish

Added by coolgw about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-12-13
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-aarch64-offline_sles15_media_basesys+srv_all_full@aarch64 fails in
upgrade_snapshots

Reproducible

Fails since (at least) Build 104.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by leli about 4 years ago

  • Subject changed from [sle][migration][SLE15SP1]test fails in upgrade_snapshots - failed at /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/console/upgrade_snapshots.pm to [sle][migration][SLE15SP1]test fails in upgrade_snapshots - snapper list no response
  • Assignee set to leli

#2 Updated by leli about 4 years ago

I cloned the job and set TIMEOUT_SCALE=2, this issue gone.
https://openqa.suse.de/tests/2348110/file/autoinst-log.txt
#################################
[2018-12-21T01:55:53.629 UTC] [debug] <<< testapi::type_string(string='snapper list | tee /dev/ttyAMA0', max_interval=250, wait_screen_changes=0, wait_still_screen=0)
[2018-12-21T01:55:54.397 UTC] [debug] /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/console/upgrade_snapshots.pm:24 called testapi::script_run
[2018-12-21T01:55:54.398 UTC] [debug] <<< testapi::send_key(key='ret', do_wait=0)
[2018-12-21T01:55:54.604 UTC] [debug] /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/console/upgrade_snapshots.pm:26 called testapi::wait_serial
[2018-12-21T01:55:54.604 UTC] [debug] <<< testapi::wait_serial(regexp='pre\s*(\|[|]){4,}\s\|\s*number\s*\|\s*before (update|online migration)\s*\|\s*important=yes', timeout=20)
[2018-12-21T01:56:19.872 UTC] [debug] >>> testapi::wait_serial: pre\s*(|[|]){4,}\s|\s*number\s*|\s*before (update|online migration)\s*|\s*important=yes: ok
##########################
From log it shown test wait 26s for the output of 'snapper list'.

So I think to increase the timeout value of 'snapper list' to 40s is ok.

#3 Updated by leli about 4 years ago

  • Subject changed from [sle][migration][SLE15SP1]test fails in upgrade_snapshots - snapper list no response to [sle][migration][SLE15SP1]test fails in upgrade_snapshots - snapper list need more time to finish
  • Status changed from New to In Progress
  • % Done changed from 0 to 50

#4 Updated by leli about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

#5 Updated by okurz about 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sled15_media_basesys+desk+we_all_full
https://openqa.suse.de/tests/2341616

#6 Updated by tinawang123 about 4 years ago

  • Status changed from Resolved to In Progress

#7 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles15_media_basesys+srv+wsm_all_full_minimal_lock
https://openqa.suse.de/tests/2429240

#10 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp3_media_base_all_full
https://openqa.suse.de/tests/2538673

#11 Updated by leli almost 4 years ago

  • % Done changed from 100 to 60

#12 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp3_media_tcm_all_full
https://openqa.suse.de/tests/2789050

#13 Updated by leli almost 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

From the latest failed log for this issue, https://openqa.suse.de/tests/2789050/file/upgrade_snapshots-full_journal.log, we can see a lot of 'susetest btrfs-balance.sh' info, so we can think the bsc#1063638 is the root cause that 'snapper list' can't return on time.

Also available in: Atom PDF