Project

General

Profile

action #45113

[sle][migration][SLE15SP1]test fails in yast2_snapper - no candidate needle with tag(s) 'desktop-runner'

Added by coolgw almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-12-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-aarch64-offline_sles12sp4_media_base_all_full@aarch64 fails in
yast2_snapper

Reproducible

Fails since (at least) Build 121.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolgw almost 4 years ago

  • Assignee set to coolgw

#2 Updated by coolgw almost 4 years ago

After investigation, this caused by timeout of check tag "pkcon-status" is too big(this caused by TIMEOUT_SCALE settting),
So try to rerun case without TIMEOUT_SCALE settting

/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 2328772 --skip-download --apikey XXX --apisecret YYY TIMEOUT_SCALE=""
#2333231: sle-15-SP1-Installer-DVD-aarch64-Build125.1-offline_sles12sp4_media_base_all_full@aarch64 -> http://openqa.suse.de/t2333231

#3 Updated by coolgw almost 4 years ago

blocked by 5119 [sle][migration][SLE15SP1]test fails in upgrade_snapshots - snapper list no response during running

#4 Updated by coolgw almost 4 years ago

  • Status changed from New to Blocked

#5 Updated by okurz almost 4 years ago

Please do not leak any API keys or secrets in public ticket trackers. I deleted your API key from OSD for security reasons. You should be able to create a new one over the webUI with no problem.

#6 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp4_media_tcm_all_full
https://openqa.suse.de/tests/2343794

#7 Updated by coolgw almost 4 years ago

  • Status changed from Blocked to New

#8 Updated by coolgw almost 4 years ago

rerun with timescale=""
/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 2328772 --skip-download --apikey xx --apisecret xx _GROUP=0 TIMEOUT_SCALE=""
Created job #2356777: sle-15-SP1-Installer-DVD-aarch64-Build125.1-offline_sles12sp4_media_base_all_full@aarch64 -> http://openqa.suse.de/t2356777

#9 Updated by coolgw over 3 years ago

coolgw wrote:

rerun with timescale=""
/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 2328772 --skip-download --apikey xx --apisecret xx _GROUP=0 TIMEOUT_SCALE=""
Created job #2356777: sle-15-SP1-Installer-DVD-aarch64-Build125.1-offline_sles12sp4_media_base_all_full@aarch64 -> http://openqa.suse.de/t2356777

blocked by libsoft token issue 1120325

#10 Updated by coolgw over 3 years ago

  • Status changed from New to Blocked

#11 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp3_media_base_def_full_lock
https://openqa.suse.de/tests/2385395

#13 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: offline_sles12sp3_media_base_def_full_lock
https://openqa.suse.de/tests/2439571

#15 Updated by coolgw over 3 years ago

  • Status changed from Blocked to Rejected

desktop-runner does not show up on alt-f2, retrying up to three times (see bsc#978027)
This issue not fixed yet, so belong to the issue, not poo.
So i close this action.

#16 Updated by okurz over 3 years ago

I does not look like the bug will be fixed anytime soon if at all. I suggest to consider a workaround or deeper investigation.

#17 Updated by leli over 3 years ago

  • Status changed from Rejected to In Progress

re-open since found it again on build 192.1.
https://openqa.suse.de/tests/2685224#step/yast2_snapper/29

#18 Updated by coolgw over 3 years ago

  • Status changed from In Progress to Blocked

Currently blocked by issue #1129504
Some comments for this issue, the issue seems happen within ensure_installed "yast2-snapper", base the test result you can see the screen saver already start so lead the case failed(alt+f2 can not take effect), so we need close screensaver before ensure-installed moudule, but currently block by grub_test issue, so after grub_test issue fixed, then we can continue validate this issue.

sub run {

  • x11_start_program('xterm');
  • turn_off_gnome_screensaver if check_var('DESKTOP', 'gnome');

    my $self = shift;
    # Make sure yast2-snapper is installed (if not: install it)
    ensure_installed "yast2-snapper";

    # Start an xterm as root
    x11_start_program('xterm');

#19 Updated by coolgw over 3 years ago

https://openqa.suse.de/tests/2756482# this is another case? no related this issue.

#20 Updated by coolgw over 3 years ago

coolgw wrote:

https://openqa.suse.de/tests/2756482# this is another case? no related this issue.

https://openqa.suse.de/tests/2754967#comments

#22 Updated by coolgw over 3 years ago

#23 Updated by coolgw over 3 years ago

  • Status changed from Blocked to Resolved

PR merge, then if issue exist we can open again.

Also available in: Atom PDF