Project

General

Profile

action #43898

[sle][migration][SLE15SP1] test fails in boot_to_desktop - trying to boot from unbootable image/device or wrong parameters specified

Added by okurz about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-11-16
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-ppc64le-media_upgrade_sles12sp3+ha+sdk_allpatterns@ppc64le fails in
boot_to_desktop

Reproducible

Fails since (at least) Build 35.18

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by mitiao about 4 years ago

i assume the problem is to boot local disk from lsof, for booting sle12 images, specify 'scsi@5' is fine

boot /pci\t/sc\t5
https://github.com/foursixnine/os-autoinst-distri-opensuse/blob/8f5512fa4ffd5987c5d24c6a0451c6774b39a1f1/lib/bootloader_setup.pm#L188

and to boot sle15 images, maybe the number of root partition is different with sle12 images, so find correct 'scsi@x' that may solve it.
since we don't have local power worker to verify what i thought, @lemon please ask someone in NUE who have local power worker to try it.

#2 Updated by zluo about 4 years ago

http://e13.suse.de/tests/10266# my ppc64le remote worker has the same problem.

There was no issue for boot SLES-15-ppc64le-GM-gnome.qcow2. The difference here:

After installation it still trys to boot up from CD image which is not correct.

Of course it should boot up directly from installed image. This will avoid any problem with CD image bootloader on ppc64le.

Anyway both way should work.

#3 Updated by mitiao about 4 years ago

zluo wrote:

http://e13.suse.de/tests/10266# my ppc64le remote worker has the same problem.

There was no issue for boot SLES-15-ppc64le-GM-gnome.qcow2. The difference here:

After installation it still trys to boot up from CD image which is not correct.

Of course it should boot up directly from installed image. This will avoid any problem with CD image bootloader on ppc64le.

Anyway both way should work.

Boot up from ISO which is for following Upgrade steps so we have to set BOOTFROM=d in this case

#4 Updated by leli about 4 years ago

  • Subject changed from [sle][migration][ppc64le] test fails in boot_to_desktop - trying to boot from unbootable image/device or wrong parameters specified to [sle][migration][SLE15SP1] test fails in boot_to_desktop - trying to boot from unbootable image/device or wrong parameters specified
  • Assignee set to leli

Update the tag so migration team can grep this ticket.

#5 Updated by leli about 4 years ago

  • Status changed from New to In Progress

This issue failed for openqa setting more argument for /usr/bin/qemu-system-ppc64 (such as +-device virtio +-serial), this may caused by VIRTIO_CONSOLE=1 since build 95.1, then new device serial will be added which caused the scsi device id changed from 5 to 6. So we need to updated the scsi boot id from 5 to 6.
lib/bootloader_setup.pm
sub boot_local_disk {
type_string_very_slow "boot /pci\t/sc\t5"; 5->6

#7 Updated by leli about 4 years ago

  • % Done changed from 0 to 60

#8 Updated by leli about 4 years ago

  • Priority changed from Normal to High

#9 Updated by leli about 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 60 to 100

Also available in: Atom PDF