Project

General

Profile

action #38810

[functional][y][sporadic] test fails in yast2_http (openqa.opensuse.org not reachable / timeout on package installation / unstable?)

Added by dimstar about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 18
Start date:
2018-07-25
Due date:
2018-08-28
% Done:

0%

Estimated time:
1.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_ncurses@64bit fails in
yast2_http

Reproducible

Fails since (at least) Build 20180604

Expected result

Last good: 20180603 (or more recent)

Further details

Always latest result in this scenario: latest

Seems we lose network after the previous runs, as zypper is no longer able to download packages from the test repo hosted on openqa.opensuse.org

History

#1 Updated by mloviska about 4 years ago

2018-07-24 17:28:41 <1> susetest(32729) [zypp++] MediaCurl.cc(doGetFileCopyFile):1499 URL: http://openqa.opensuse.org/assets/repo/openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20180723/media.1/media
2018-07-24 17:28:41 <1> susetest(32729) [zypp++] MediaMultiCurl.cc(doGetFileCopy):1361 HTTP response: 200
...
2018-07-24 17:31:41 <1> susetest(6388) [zypp++] MediaCurl.cc(doGetFileCopyFile):1499 URL: http://openqa.opensuse.org/assets/repo/openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20180723/media.1/media
2018-07-24 17:31:41 <3> susetest(6388) [zypp] MediaCurl.cc(doGetFileCopyFile):1563 curl error: 7: Failed to connect to openqa.opensuse.org port 80: Network is unreachable, temp file size 0 bytes.
2018-07-24 17:31:41 <5> susetest(6388) [zypp] Exception.cc(log):166 MediaCurl.cc(evaluateCurlCode):1172 THROW:    Download (curl) error for 'http://openqa.opensuse.org/assets/repo/openSUSE-Tumbleweed-oss-i586-x86_64-Snapshot20180723/media.1/media':
2018-07-24 17:31:41 <5> susetest(6388) [zypp] Exception.cc(log):166 Error code: Connection failed
2018-07-24 17:31:41 <5> susetest(6388) [zypp] Exception.cc(log):166 Error message: Failed to connect to openqa.opensuse.org port 80: Network is unreachable

Repo was refresh without any issues 6 minutes later
https://openqa.opensuse.org/tests/712660#step/zypper_ref/2

I guess, o3 system logs might shed some light about this issue.

#3 Updated by okurz about 4 years ago

  • Subject changed from test fails in yast2_http (openqa.opensuse.org not reachable) to [functional][y][sporadic] test fails in yast2_http (openqa.opensuse.org not reachable / timeout on package installation / unstable?)
  • Due date set to 2018-08-28
  • Target version set to Milestone 18

While at first the issue seemed to have been clearly reproducible the test turned good again but failed once recently nevertheless: https://openqa.opensuse.org/tests/720173#step/yast2_http/6 This seems to be a problem in not waiting long enough for the package to be installed. I suggest to check stability of this test module and ensure it provides consistent stable results. mloviska thanks for your initial investigation. Feel free to keep it or unassign.

#4 Updated by mloviska about 4 years ago

There are few minor changes in workflow, which requires a bit of needling and code change prior to gather more stats.

#6 Updated by mloviska about 4 years ago

  • Status changed from New to Feedback

#7 Updated by riafarov about 4 years ago

  • Estimated time set to 1.00 h

#8 Updated by riafarov about 4 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF