Project

General

Profile

action #38711

[functional][sle15][y] test fails in welcome - shortcut for product changed

Added by nicksinger about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 18
Start date:
2018-07-23
Due date:
2018-08-28
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP1-Installer-DVD-x86_64-create_hdd_sled_gnome@64bit-virtio-vga fails in
welcome. If you compare it to SLE15SP0 and take a look at the source code you'll realize that the shortcut for SLED changed once again.

We should not introduce yet another if-branch here but rather rewrite the code to select modules needle-based.

Reproducible

Fails since Build 13.2 (SLE15SP1) (current job)

Acceptance Criteria/Expected result

AC1: Rewrite the module "welcome" to select the desired product based on needles. This should work for graphical installations as well as for text installations.


Related issues

Related to openQA Tests - action #39797: [functional][y][fast] test fails in welcome - necessary adaptions to new system_role codeResolved2018-08-152018-08-28

History

#1 Updated by okurz about 3 years ago

  • Subject changed from [functional][15SP1][fast][y] test fails in welcome - shortcut for product changed to [functional][sle15][y] test fails in welcome - shortcut for product changed
  • Due date set to 2018-08-28
  • Status changed from New to Workable
  • Target version set to Milestone 18

don't need to rush SLE15SP1

#2 Updated by JERiveraMoya about 3 years ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

I am going to start to prepare some code. I think the changes in the code only will be in the sle15+ part of the code, so it should be safe even it is the first test executed in many test suites. I have to evaluate the scope to see if we might want to have two codes living at the same time working just for a while.

#3 Updated by JERiveraMoya about 3 years ago

  • Status changed from In Progress to Feedback

#4 Updated by JERiveraMoya about 3 years ago

  • Status changed from Feedback to In Progress

#5 Updated by JERiveraMoya about 3 years ago

  • Status changed from In Progress to Resolved

VR in OSD shows that all jobs failing with this issue ins SLE15 SP1 are now fixed:
skip_registration+sled+all-packages+activate_existing || gnome_sled || create_hdd_sled_gnome || create_hdd_sled_gnome+development

Also run this one in textmode to ensure behavior with shortcuts in preserved.

#6 Updated by JERiveraMoya about 3 years ago

  • Related to action #39797: [functional][y][fast] test fails in welcome - necessary adaptions to new system_role code added

Also available in: Atom PDF