Project

General

Profile

action #36258

[QAM][CAASP] kubectl get fails

Added by pgeorgiadis over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-05-16
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

This is happening ~once per 2 weeks. I don't know what's wrong since DEX is up and running. I would say, let's try to fix this by issuing the command again. If it fails 10 times in a row, then we can file a product bug.

openQA test in scenario caasp-2.0-CaaSP-DVD-Incidents-x86_64-QAM-CaaSP-controller@qam-caasp_x86_64 fails in
stack_kubernetes

Reproducible

Fails since (at least) Build :7219:bash.1526391680 (current job)

Expected result

Last good: :7191:icu.1526390919 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pgeorgiadis over 3 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100

#2 Updated by pgeorgiadis over 3 years ago

  • Status changed from In Progress to Resolved

Another reason might be that Kubernetes is killing DEX on the worst time possible because of the livenessProve. Latest PR https://github.com/kubic-project/salt/pull/424/files#diff-d2087569dc8cb0eb3fbaaa68c895b9c0R74 makes this a bit less strict.

Also available in: Atom PDF