Project

General

Profile

action #33385

[QAM][CAASP] Fix the k8s conformance test to parse new output

Added by pgeorgiadis over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-03-16
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario caasp-2.0-CaaSP-DVD-Incidents-x86_64-QAM-CaaSP-controller@qam-caasp_x86_64 fails in
stack_conformance

Sometimes the tests require more than 1.30 hour. This happened quite a few times now:
e.g. https://openqa.suse.de/tests/1550131
e.g. https://openqa.suse.de/tests/1550285 , etc

Reproducible

Fails since (at least) Build :6868:grub2.1521115306

Expected result

Last good: :6812:rdma-core.1521115525 (or more recent)

Further details

Always latest result in this scenario: latest

My solution is to increase the timeout from 90 minutes up to 120 minutes.
This will not delay any test without any reason, simply because if the test finishes earlier, it will exit the loop ;)

History

#2 Updated by mkravec over 3 years ago

I does not need more time, just conformance report have few extra lines..

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4638

#3 Updated by pgeorgiadis over 3 years ago

Indeed. Should we grep also 'Test Suite Passed' at the last line?

#4 Updated by pgeorgiadis over 3 years ago

  • Subject changed from [QAM][CAASP] k8s conformance tests need more time to [QAM][CAASP] Fix the k8s conformance test to parse new output

#5 Updated by pgeorgiadis over 3 years ago

  • Status changed from In Progress to Resolved

We merged https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4638 which complies with the official k8s readme for reviewing the test results.
This will stop breakage in maintenance.

When they will reply we will either close or merge also: https://github.com/cncf/k8s-conformance/issues/172

Also available in: Atom PDF