Project

General

Profile

action #33364

[sle][functional][y][yast] test encrypted disk activation with autoyast

Added by riafarov about 3 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Low
Assignee:
Target version:
SUSE QA tests - SLE 15 SP3
Start date:
2018-03-16
Due date:
% Done:

0%

Estimated time:

Description

As an outcome of regression we got in https://bugzilla.suse.com/show_bug.cgi?id=1085439 we would like to cover encrypted disk activation with ay.

Test should cover installation activating existing encrypted partitions during probe based on the profile from the attachment

We can use image from cryptlvm job.

We can use AUTOYAST_CONFIRM setting to sync with installation and validate activation of the partition same way as we do already for cryptlvm+activate existing
(see https://openqa.suse.de/tests/5163223#step/installation/4).

In the profile it can be enabled by injecting following section:

<general>
  <mode>
    <confirm config:type="boolean">true</confirm>
  </mode>
</general>

Acceptance criteria:

  1. Test activating existing encrypted partitions is running for SLE 15 SP3 qemu 64bit
  2. Activation of the partition is validated
reuse-encrypted.xml (7.39 KB) reuse-encrypted.xml riafarov, 2018-03-16 11:35

History

#1 Updated by okurz about 3 years ago

  • Target version set to Milestone 17

#2 Updated by okurz almost 3 years ago

  • Subject changed from [sle][functional][yast] test encrypted disk activation with autoyast to [sle][functional][y][yast] test encrypted disk activation with autoyast

#3 Updated by okurz almost 3 years ago

  • Target version changed from Milestone 17 to Milestone 21+

#4 Updated by okurz almost 3 years ago

  • Target version changed from Milestone 21+ to Milestone 21+

#5 Updated by okurz over 2 years ago

  • Target version changed from Milestone 21+ to Milestone 24

#6 Updated by okurz about 2 years ago

  • Priority changed from Normal to Low
  • Target version changed from Milestone 24 to future

let's focus more on improving our current tests and workflows first. Putting to "holding tank" :)

#7 Updated by riafarov 6 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (New test)

#8 Updated by riafarov 4 months ago

  • Description updated (diff)
  • Status changed from New to Workable

#9 Updated by JRivrain 4 months ago

  • Status changed from Workable to In Progress
  • Assignee set to JRivrain

#10 Updated by JRivrain 3 months ago

PR https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/11670
The used xml was generated with yast-clone, I see that other profiles for test suites are much smaller so I guess it shoudl be generated "by hand". The one in attachment was outdated and not fitting if we would re-use the disk from cryptlvm. I'll fix this after vacations.

#11 Updated by JRivrain 3 months ago

  • Status changed from In Progress to Feedback

#12 Updated by JRivrain 3 months ago

  • Status changed from Feedback to In Progress

Test fails here https://openqa.suse.de/tests/5282295#step/installation/25
Unlike in the test runs, the needle "bios-boot" does not match because we cannot see "Seabios" written at the top left corner :(

#14 Updated by JRivrain 3 months ago

  • Status changed from In Progress to Feedback

#15 Updated by JRivrain 3 months ago

  • Status changed from Feedback to Closed

passed 3 builds

#16 Updated by riafarov about 2 months ago

  • Target version changed from future to SLE 15 SP3

Also available in: Atom PDF