Project

General

Profile

action #30361

[qam] Job dependencies get lost

Added by pgeorgiadis over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-01-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Sometimes, if jobs can't get resources / fail / incomplete - and openqa tries to restart the cluster. The problem is that job dependencies get lost/scrambled. So, in CaaSP we end up with stuff like 1 child job, but no parent.

e.g. https://openqa.suse.de/tests/1387512#settings
has

Children
Parallel - QAM-CaaSP-admin

while the expected would be: https://openqa.suse.de/tests/1383291#settings

Parents
Parallel - QAM-CaaSP-controller     failed
Children
Parallel - QAM-CaaSP-admin  failed

History

#1 Updated by pluskalm over 3 years ago

  • Subject changed from Job dependencies get lost to [qam] Job dependencies get lost

#2 Updated by coolo over 3 years ago

  • Status changed from New to Resolved

https://github.com/os-autoinst/openQA/pull/1623 - we're still optimizing it though

Also available in: Atom PDF