Project

General

Profile

action #28639

Verify that yast network module doesn't crash in case of wrong configuration in ifcfg

Added by riafarov about 3 years ago. Updated 5 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA tests - SLE 15 SP3
Start date:
2017-11-30
Due date:
% Done:

0%

Estimated time:

Description

This test scenario occurred in the customer setup, see https://bugzilla.suse.com/show_bug.cgi?id=1061306

YaST must not break if it finds something unexpected in network configuration files (ifcfg). The fact is, that if anything changes in the future, we need to be ready. Customers can add some values either by a mistake or even intentionally, for instance, if they want/need it for some reason (that might be unknown to us).

Scope is 64bit only. We can add this scenario to yast2_gui test suite.

Test scenario should include at least following steps:

  1. Put misconfigured settings in ifcfg file e.g. ETHERDEVICE setting which is expected to be used for VLANs only: ETHERDEVICE='eth0'
  2. Run lan module of the yast nd verify it doesn't crash

Tasks

  1. Implement automated test
  2. Add to the SLE Functional job group

Acceptance criteria:

  1. Automated test runs in production and verifies that lan yast module doesn't crash when ifcfg file contains invalid configuration

History

#1 Updated by okurz about 3 years ago

  • Target version set to Milestone 16

#2 Updated by okurz about 3 years ago

riafarov I suggested it for a rather late milestone but you can discuss with PO or suggest something more specific depending on where you see the priority.

#3 Updated by okurz almost 3 years ago

  • Subject changed from [sle][functional][yast] Create test to verify that yast network module doesn't crash in case of wrong configuration in ifcfg to [sle][functional][yast][y] Create test to verify that yast network module doesn't crash in case of wrong configuration in ifcfg
  • Target version changed from Milestone 16 to Milestone 18

M16 seems to be too ambitious

#4 Updated by okurz over 2 years ago

  • Target version changed from Milestone 18 to Milestone 18

#5 Updated by okurz over 2 years ago

  • Target version changed from Milestone 18 to future

Currently not happening

#6 Updated by riafarov 4 months ago

  • Project changed from openQA Tests to qe-yast
  • Subject changed from [sle][functional][yast][y] Create test to verify that yast network module doesn't crash in case of wrong configuration in ifcfg to Verify that yast network module doesn't crash in case of wrong configuration in ifcfg
  • Category deleted (New test)

#7 Updated by riafarov about 2 months ago

  • Description updated (diff)
  • Status changed from New to Workable

#8 Updated by JRivrain about 1 month ago

  • Status changed from Workable to In Progress
  • Assignee set to JRivrain

#9 Updated by JRivrain about 1 month ago

Nowadays, ETHERDEVICE='eth0' in ifcfg-eth0 marks eth0 as parent device of eth0, or whatever we wrote between quotes (eg ETHERDEVICE='Hahahasomuchfun'). Does not crash, but then we have a different problem, probably not a bug though. If the purpose is to see whether putting a wrong entry provokes a crash, we should find something else probably.
Otherwise if we put a typo like "THERDEVICE='eth0'", the entry gets ignored. I guess testing this may be relevant in the scope of this ticket. Scope that otherwise I'm having hard time to define here, as there can be litteraly an inifinity of mistakes in a hand-written config file.

I guess a good starting point can be that script from the bug report https://bugzilla.suse.com/attachment.cgi?id=746128

#11 Updated by JRivrain about 1 month ago

  • Status changed from In Progress to Feedback

PR merged, waiting for next build.

#12 Updated by JRivrain 29 days ago

  • Status changed from Feedback to Closed

Next build passed

#13 Updated by riafarov 5 days ago

  • Target version changed from future to SLE 15 SP3

Also available in: Atom PDF