Project

General

Profile

action #27856

[opensuse][desktop][wayland][sporadic]test fails in sshxterm - workaround(s) for "fragile" wayland

Added by okurz over 3 years ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-11-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-kde-wayland@64bit_virtio fails in
sshxterm asserting an xterm instead of the shown konsole.

Reproducible

Fails sporadically from time to time.

Expected result

Last good: https://openqa.opensuse.org/tests/534668#step/sshxterm/2

Problem

‎[‎17 Nov 2017 14:26:47‏] ‎<‎okurz‎>‎ apparently the problem is in https://openqa.opensuse.org/tests/534668#step/sshxterm/2 that only "erm" ends up in the desktop-runner, not "xterm". Then it starts konsole with a call to "su", therefore looking different and asking for password. So have you ever seen something like this before? If yes, then I would create a progress ticket to fix it
‎[‎17 Nov 2017 14:28:04‏] ‎<‎DimStar‎>‎ have a look at 'last test' of this run; it is failing all over the place; yesterday it was five runs with 5 different modules failing
[‎17 Nov 2017 14:29:10‏] ‎<‎DimStar‎>‎ a common error seems indeed the launcher not to get all inputs (but I rather think thats plasma's wayland compositor not being up-to-par yet than being an openQA issue)
‎[‎17 Nov 2017 14:29:23‏] ‎<‎DimStar‎>‎ the same does not happen when running the KDE-X tests
‎[‎17 Nov 2017 14:29:33‏] ‎<‎DimStar‎>‎ (which implies more a boo ref than a progress item)
‎[‎17 Nov 2017 14:32:46‏] ‎<‎okurz‎>‎ so that's the thing then, let's do a proper bug and a workaround for that. And *that* could be a progress ticket: to do a workaround for a wayland issue. And *then* someone can blog about how openQA is so awesome it supports wayland development :)
‎[‎17 Nov 2017 14:35:26‏] ‎<‎DimStar‎>‎ seems I travelled in time: https://bugzilla.opensuse.org/show_bug.cgi?id=1064836 :)
‎[‎17 Nov 2017 14:35:28‏] ‎<‎|Anna|‎>‎ openSUSE bug 1064836 in openSUSE Tumbleweed (KDE Workspace (Plasma)) "[Build 20171022] Plasma/Wayland is very fragile" [Normal,New]

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz about 3 years ago

  • Subject changed from [opensuse][sporadic]test fails in sshxterm - workaround(s) for "fragile" wayland to [opensuse][desktop][wayland][sporadic]test fails in sshxterm - workaround(s) for "fragile" wayland

#2 Updated by GraceWang about 2 months ago

  • Status changed from New to Resolved

Checked in the latest TW, the sshxterm is passed https://openqa.opensuse.org/tests/1774439#step/sshxterm/7
Also checked the results history, and didn't find ssdxterm failure in the recent two months.
So, I will close this ticket as resolved.

Also available in: Atom PDF