Project

General

Profile

action #27853

[sle][functional][u][easy] extend SUSEConnect test with minimal UI checks

Added by okurz over 2 years ago. Updated 3 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
SUSE QA tests - Milestone 30
Start date:
2017-11-17
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-minimal+proxy_SCC-postreg_SUSEconnect@64bit in
suseconnect_scc shows that the test passes but the output is … suboptimal, e.g. "--list-extensions" does not list the "server applications" module even though it's there as it can be activated later on.

Acceptance criteria

  • AC1: There is a needle check asserting on correct rendering of the console UI of SUSEConnect
  • AC2: There is a soft-fail needle with a bugref for the missing server applications module -> https://bugzilla.suse.com/show_bug.cgi?id=1064264 , being VERIFIED FIXED

Tasks

  • Search for an existing UI test case. If the output layout of SUSEConnect --list-extensions is already tested, this ticket can be resolved. If not, the graphical output of the command needs to be tested in suseconnect_scc
  • Add a assert_screen call after the "--list-extensions" call (0.1-1h)
  • Add a needle with soft-fail reference to the bug that nsinger create(s/d) (0.1-0.5h)

Further details

I think a needle check with assert_screen is correct here because even though it's about a console application we want to check the very least of "UI" here as the customer is supposed to use the same. correct rendering is up to the ticket assignee to decide what makes sense.

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #66826: [SLE][Migration][SLE15SP2][enhance] Check SUSEConnect --list-extensions, SUSEConnect --status-text,zypper lr include all module informationResolved2020-05-14

History

#1 Updated by riafarov over 2 years ago

  • Status changed from In Progress to Workable

#2 Updated by okurz over 2 years ago

  • Category changed from Bugs in existing tests to New test
  • Target version changed from Milestone 13 to Milestone 16

that's actually a "new test". Maybe something we will be able to do in M16

#3 Updated by okurz about 2 years ago

  • Subject changed from [sle][functional][easy]extend SUSEConnect test with minimal UI checks to [sle][functional][u][easy] extend SUSEConnect test with minimal UI checks
  • Target version changed from Milestone 16 to Milestone 19

M16 is too ambitious it seems

#4 Updated by okurz about 2 years ago

  • Target version changed from Milestone 19 to Milestone 19

#5 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 19 to future

#6 Updated by dheidler over 1 year ago

okurz:

Regarding AC1: Can you rephrase this - my grammar parser fails here

Regarding AC2: Do we have a bsc here?

#7 Updated by okurz over 1 year ago

  • Description updated (diff)

dheidler wrote:

Regarding AC1: Can you rephrase this - my grammar parser fails here

yes, I tried to.

Regarding AC2: Do we have a bsc here?

I crossed of this point as the bug is VERIFIED FIXED since then so I think this is not needed anymore.

#8 Updated by okurz over 1 year ago

https://trello.com/c/q1OVLDwY/724-cnt-nicer-output-when-zypper-encounters-errors is an interesting feature request as outcome from agraul and me using SUSEConnect with our "observations" noted down in https://bugzilla.suse.com/show_bug.cgi?id=1117541

#11 Updated by okurz over 1 year ago

  • Status changed from Workable to Blocked
  • Assignee set to okurz

Seems some development is ongoing by hurhaj already in the related ticket, let's wait for that.

#12 Updated by SLindoMansilla over 1 year ago

SUSEConnect doesn't work on transactional-server role, and the suggestions output may reference to "transactional-server register".

See #42929

Not sure if we want to cover this, and if we want to cover it on this ticket.

#14 Updated by okurz over 1 year ago

  • Status changed from Blocked to Workable
  • Assignee deleted (okurz)
  • Target version changed from future to Milestone 24

#43136 is finished, should be easy for us to schedule the test module within product validation tests.

#15 Updated by okurz over 1 year ago

Suggestion: First schedule a simple scenario for both SLE12 and SLE15 with REGRESSION=suseconnect, later think about extending for what might be still missing (see description).

#16 Updated by okurz over 1 year ago

  • Status changed from Workable to New
  • Priority changed from Normal to Low
  • Target version changed from Milestone 24 to future

let's focus more on improving our current tests and workflows first. Putting to "holding tank" :)

#17 Updated by szarate 4 months ago

  • Assignee set to mgriessmeier

Matthias to check what's needed here

#18 Updated by SLindoMansilla 3 months ago

  • Assignee changed from mgriessmeier to SLindoMansilla

We have to prepare this before a grooming meeting.
The idea would be to use script_output to check that the expected SLE module are shown.

A screenshot will not cover the whole output: https://openqa.suse.de/tests/4145661#step/suseconnect_scc/10

#19 Updated by szarate 3 months ago

  • Assignee changed from SLindoMansilla to mgriessmeier

A side note, we can simply use the serial console instead, and use the json output (-s option) of SUSEConnect in combination with script_output, so that perl does all the heavylifting here instead.

#20 Updated by SLindoMansilla 3 months ago

  • Assignee changed from mgriessmeier to SLindoMansilla

#21 Updated by SLindoMansilla about 2 months ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Assignee deleted (SLindoMansilla)
  • Priority changed from Low to Normal
  • Target version changed from future to Milestone 30
  • Estimated time set to 42.00 h

#22 Updated by szarate about 2 months ago

  • Related to action #66826: [SLE][Migration][SLE15SP2][enhance] Check SUSEConnect --list-extensions, SUSEConnect --status-text,zypper lr include all module information added

#23 Updated by zluo 29 days ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

okay, checking and add assert_screen call after the "--list-extensions"

#25 Updated by zluo 27 days ago

  • Status changed from In Progress to Resolved

#26 Updated by zluo 23 days ago

  • Status changed from Resolved to In Progress

#27 Updated by zluo 23 days ago

needle match only Server Applications Module 15 SP2 and Web and Scripting Module 15 SP2 without matching neither architecture, nor the instructions to activate/deactivate

#28 Updated by dheidler 23 days ago

Just make sure to match also the spaces before the module names to check for indentation:

SUSEConnect -l | grep "$(echo -en '            \e\[1mLegacy Module')"

Also available in: Atom PDF