Project

General

Profile

action #26950

[qam] test fails in wireshark - Status bar does not show live capture status

Added by osukup almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-10-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

looks like wireshark has changed GUI ?

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-gnome@64bit fails in
wireshark

Reproducible

Fails since (at least) Build 20171022-1 (current job)

Expected result

Last good: 20171020-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by osukup almost 5 years ago

  • Subject changed from test fails in wireshark to [qam] test fails in wireshark
  • Assignee set to vsvecova

#2 Updated by vsvecova almost 5 years ago

  • Status changed from New to In Progress

I believe this is a timing issue, possibly caused by slow network or similar issues.

I recall that this problem has occurred before and eventually passed after restarting.

I'll look into it.

#3 Updated by coolo over 4 years ago

  • Status changed from In Progress to Resolved

this hasn't been seen in a while - the current wireshark failure is of a different nature

#4 Updated by vsvecova over 4 years ago

  • Subject changed from [qam] test fails in wireshark to [qam] test fails in wireshark - Status bar does not show live capture status
  • Status changed from Resolved to In Progress

I'm reopening this issue as I have noticed a couple more occurrences in the last few days.

Example: https://openqa.suse.de/tests/1351623#step/wireshark/44

The wireshark status bar does not show the expected status message , even though wireshark is still capturing traffic.

#5 Updated by vsvecova over 4 years ago

  • Status changed from In Progress to Resolved

This actually looks like it could be a wireshark bug, so I opened bsc#1075587.

I also created a workaround needle:
https://gitlab.suse.de/openqa/os-autoinst-needles-sles/commit/1ef2e3fe01445ff964e99e71442575e7f7aa39d1

The needle encompasses the same area as the original one, where we expect the "live capture in progress" status message, but the workaround needle expects to find there the path to the cap file instead. Thus we make sure that the workaround needle doesn't match prematurely in cases where bsc#1075587 does not manifest.
To verify that the capturing is actually still in progress, the workaround needle checks that the "start" button is gray and the "stop" button is clickable.

Also available in: Atom PDF