Project

General

Profile

action #25446

[sle][functional][gnome]multi_user_dm needs adaptation

Added by dimstar over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-09-20
Due date:
2017-10-25
% Done:

0%

Estimated time:
Difficulty:

Description

For 'ever', multi_user_dm for GNOME failed to tear down GDM, add the users and restart GDM successfully. This is finally working in Tumbleweed (with GNOME 3.26.0) (see https://bugzilla.opensuse.org/show_bug.cgi?id=1018836 for the previous failure)

But the test code now has wrong expectations, that on start 'Bernhard' will be preselected and a key-down press pick 'User#01'; this is not totally illogical, per se, but not true.

When gdm starts, the mouse 'hovers' over 'User#03', which moves the 'user select bar' to that user; Pressing 'down' now picks 'User#04'; This feels visually more correct than the mouse hovering over a user, and keypress then starting at the top of the screen.

The 'easiest' way out here would likely be an assert_and_click on user01 directly


Related issues

Related to openQA Tests - action #25726: [sle][functional] test fails in shutdown, as user is not selectedResolved2017-10-02

History

#1 Updated by okurz over 5 years ago

  • Category set to Bugs in existing tests
  • Priority changed from Normal to High

#2 Updated by okurz over 5 years ago

  • Subject changed from [gnome]multi_user_dm needs adaptation to [sle][functional][gnome]multi_user_dm needs adaptation
  • Due date set to 2017-10-11

#3 Updated by riafarov over 5 years ago

  • Assignee set to riafarov

#4 Updated by riafarov over 5 years ago

  • Related to action #25726: [sle][functional] test fails in shutdown, as user is not selected added

#6 Updated by okurz over 5 years ago

PR merged, test on o3 retriggered, failed trying to startup the DM again: https://openqa.opensuse.org/tests/500210

Retriggered as https://openqa.opensuse.org/tests/500405#live , maybe works now?

#7 Updated by riafarov over 5 years ago

  • Status changed from Feedback to In Progress

#8 Updated by riafarov over 5 years ago

Cannot reproduce issue locally, trying to figure out if can be resolved with timing workarounds:
https://openqa.opensuse.org/tests/501491# run with TIMEOUT_SCALE=5 and VNC_TYPING_LIMIT=10

#9 Updated by riafarov over 5 years ago

Issue still occurs in production, increase of timeout in the code didn't help. Investigating.

#10 Updated by riafarov over 5 years ago

There is a bug related to qemu video driver, I need to collect more information. Test adjustment mentioned in the ticket worked fine: https://openqa.opensuse.org/tests/502895
However there are other problems which prevent test from succeeding.

#11 Updated by okurz over 5 years ago

  • Due date changed from 2017-10-11 to 2017-10-25

#12 Updated by riafarov over 5 years ago

  • Status changed from In Progress to Resolved

Job fails due to the bug in the product: https://bugzilla.opensuse.org/show_bug.cgi?id=1063060 Adjusted part seems to work fine. Tracking the bug state.

Also available in: Atom PDF