Project

General

Profile

action #18984

test fails in java - java-1_9_0 was renamed to java-9* (currently -9-internal)

Added by dimstar almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-05-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_in_textmode@64bit fails in
java

Reproducible

Fails since (at least) Build 20170324

Expected result

Last good: 20170324 (or more recent)

Further details

Always latest result in this scenario: latest

More background:

Java is in progress of changing their versioning scheme (see http://openjdk.java.net/jeps/223 ) - currently this means it's called java-9-internal.

In the past we had java-1_9_0 excluded, as this is not yet production ready code, but is required in TW in order to further stabilize it. I'd suggest we also treat this 9-internal version the same way

History

#1 Updated by riafarov over 5 years ago

  • Status changed from New to In Progress
  • Assignee set to riafarov

In latest many tests fail due to missing wget, as well as java test:
https://openqa.opensuse.org/tests/404592

Investigate this issue first and then proceed with a fix to java 9 version issue.

#3 Updated by riafarov over 5 years ago

Done:
Wget issue is resolved
PR for fix: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2944

Verified that test will work normally when java 9 is released and won't have any -internal -ea prefixes.

In progress:
Setup openqa on VM to perform verification run.

#4 Updated by riafarov over 5 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF