Project

General

Profile

action #112052

[sle][migration][sle15sp5][SAP] - test fails in netweaver_test_instance - It needs 1h 18m 15s to finish

Added by hjluo 2 months ago. Updated 2 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2022-06-06
Due date:
% Done:

100%

Estimated time:
3.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP4-Full-ppc64le-migration_offline_dvd_sles4sap15sp1@ppc64le-2g fails in
netweaver_test_instance

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

In case migration_offline_dvd_sles4sap15sp1@ppc64le-2g on 151.1 build on ppc64le
http://openqa.nue.suse.com/tests/8751126#step/netweaver_test_instance/139
It needs 1h 18m 15s to finish, but in the previous build, it just needs 1-2 minutes.

Reproducible

Fails since (at least) Build 151.1 (current job)

Expected result

Last good: 148.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by hjluo 2 months ago

  • Subject changed from [sle][migration][sle15sp4][SAP] - test fails in netweaver_test_instance - It needs 1h 18m 15s to finish to [sle][migration][sle15sp5][SAP] - test fails in netweaver_test_instance - It needs 1h 18m 15s to finish

#2 Updated by coolgw 2 months ago

try rerun job, check whether sporadic issue
https://openqa.suse.de/t8945536

#3 Updated by coolgw 2 months ago

/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 8751126 _GROUP=0 --skip-download
Created job #8945540: sle-15-SP4-Full-ppc64le-Build151.1-migration_offline_dvd_sles4sap15sp1@ppc64le-2g -> http://openqa.suse.de/t8945540

#4 Updated by coolgw 2 months ago

  • Assignee set to coolgw

I suppose this indeed sporadic issue since http://openqa.suse.de/t8945540 start show OK now.
But my view if any failed happen, the module should pop up with red

#5 Updated by coolgw 2 months ago

It seems some choke happen on serial port when execute enter_cmd "exec bash" base log analyse.
sub user_change {
...
# Change to SAP Admin user
enter_cmd "su - $sapadmin";
...
enter_cmd "exec bash"; <====

# We need to change the 'serial_term_prompt' value for 'wait_serial'
my $serial_term_prompt = "$sapadmin> ";
enter_cmd(qq/PS1="$serial_term_prompt"/); <===
wait_serial(qr/PS1="$serial_term_prompt"/) if testapi::is_serial_terminal;
$testapi::distri->{serial_term_prompt} = "$serial_term_prompt";

}

#6 Updated by okurz 2 months ago

/usr/share/openqa/script/clone_job.pl --from http://openqa.suse.de --host http://openqa.suse.de 8751126 _GROUP=0 --skip-download

I suggest to use instead

openqa-clone-job --within-instance http://openqa.suse.de 8751126 _GROUP=0

Thanks a lot :)

#7 Updated by coolgw 2 months ago

  • Status changed from New to Rejected
  • % Done changed from 0 to 100
  • Estimated time set to 3.00 h

Also available in: Atom PDF