Project

General

Profile

action #105402

[sle][migration][sle15sp4][Regression]test fails in check_upgraded_service - userdel failed after logout

Added by coolgw 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Spike/Research
Target version:
-
Start date:
2022-01-25
Due date:
% Done:

100%

Estimated time:
12.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP4-Regression-on-Migration-from-SLE15-SPx-s390x-online_sles15sp2_ltss_pscc_basesys-srv-desk-dev-contm-lgm-tsm-wsm_all_full_x11@s390x-kvm-sle12 fails in
check_upgraded_service

Test suite description

Reproducible

Fails since (at least) Build 84.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by leli 4 months ago

User 'test' already logout, but the process still used by 'test' user, I think it maybe the quit cmd run but user 'test' related process may need more time to quit.

#2 Updated by leli 4 months ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20
  • Estimated time set to 12.00 h

Add some waiting time before remove the user to ensure user related process quit. Wait http://openqa.nue.suse.com/tests/8025624#live to verify.

#3 Updated by leli 4 months ago

Add judgement for process of user 'test' to wait it quit before remove user.

Wait https://openqa.nue.suse.com/tests/8033187#live to verify.

#5 Updated by leli 4 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100

PR merged, since the case blocked by other issues on build 88.1, will keep an eye the later results.

Also available in: Atom PDF